July 28, 2014

Google Wallet's tap and pay soon to be exclusive to KitKat and up

wallet_in_action

Google will soon be cutting off support for the tap and pay feature on devices not running yet running KitKat. Pre-KitKat devices aren’t quite as secure as devices running 4.4 and up thanks to some firmware updates introduced in the latest version.

In laymen’s terms, the new firmware allows the wallet app and the processor to provide the protection, which is why it will no longer be supported on older versions of the OS.

Here’s Google’s official statement:

We wanted to let you know about an update to Google Wallet that might change the way you use the app. Right now it looks like you’re using tap and pay with a device running an Android version older than 4.4 KitKat. On the newest version of Android, tap and pay works with different technology for an improved experience. As a result, starting on A​p​r​i​l 1​4, 2​0​1​4, tap and pay will no longer work for devices with older Android versions.

Tap and pay will be available for most devices running Android 4.4 KitKat. If you are able to upgrade to KitKat now, you can check if your device supports tap and pay. Supported devices will display a tile in your “My Wallet” screen that tells you to set up tap and pay. For devices that are not eligible for Android 4.4 KitKat or don’t support tap and pay, you can still use the Google Wallet app to store all of your loyalty cards and offers, send money to your friends, view your orders, and use the Google Wallet Card to make purchases.

We apologize for any inconvenience this may cause and thank you for continuing to be a loyal Wallet user.

If you have any questions, please visit our Help Center. Sincerely, The Google Wallet Team

Anyone out these think this will pose a serious issue? Anyone using this feature on a device running Jellybean or below?
Tell us your thoughts in the comments below.