<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="http://www.androidguys.com/xmlrpc.php" />
<meta property="og:image" content="http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080.png" /><meta name="author" content="Matt Adams">
<link rel="icon" type="image/png" href="http://www.androidguys.com/wp-content/uploads/2018/04/ag-favicon-2018.png">

<title>A new Android P update, the Moto Z3 Play, and more (Episode 11)</title>
<meta name="description" content="Matt and Andrew discuss an update for the Android P Developer Preview, the first smartwatch from fashion designer Marc Jacobs and more! Click here to listen" />
<meta name="original-source" content="http://www.androidguys.com/2018/06/07/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11/" />
<link rel="canonical" href="http://www.androidguys.com/2018/06/07/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11/" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"http:\/\/www.androidguys.com\/","sameAs":["http:\/\/www.facebook.com\/androidguys","http:\/\/www.instagram.com\/androidguys","https:\/\/twitter.com\/androidguys"],"@id":"http:\/\/www.androidguys.com\/#organization","name":"AndroidGuys","logo":""}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="AndroidGuys &raquo; Feed" href="http://www.androidguys.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="AndroidGuys &raquo; Comments Feed" href="http://www.androidguys.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="AndroidGuys &raquo; Android P Beta 2, Honor Turbo Charging, and Moto Z3 Play (Episode 11) Comments Feed" href="http://www.androidguys.com/2018/06/07/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11/feed/" />
<script type="8659d7c75a0ee512be482942-text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.androidguys.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.6"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css' href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css' href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='http://fonts.googleapis.com/css?family=Oswald%3A400%2C700&#038;ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css' href='http://www.androidguys.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='http://www.androidguys.com/wp-content/themes/Newspaper2/style.css?ver=7.6.1' type='text/css' media='all' />
<script type="8659d7c75a0ee512be482942-text/javascript" src='http://www.androidguys.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type="8659d7c75a0ee512be482942-text/javascript" src='http://www.androidguys.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://www.androidguys.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.androidguys.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.androidguys.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.8.6" />
<link rel='shortlink' href='http://www.androidguys.com/?p=139438' />
<link rel="alternate" type="application/json+oembed" href="http://www.androidguys.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.androidguys.com%2F2018%2F06%2F07%2Fandroid-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.androidguys.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.androidguys.com%2F2018%2F06%2F07%2Fandroid-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11%2F&#038;format=xml" />
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://www.androidguys.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><link rel="amphtml" href="http://www.androidguys.com/2018/06/07/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11/amp/">

<script type="8659d7c75a0ee512be482942-">
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var tds_general_modal_image="yes";
var td_ajax_url="http:\/\/www.androidguys.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.6.1";
var td_get_template_directory_uri="http:\/\/www.androidguys.com\/wp-content\/themes\/Newspaper2";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#0277bd";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<style>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</style>
<script type="8659d7c75a0ee512be482942-">
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2973238-3', 'auto');
  ga('send', 'pageview');

</script><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>


<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="AndroidGuys" />
<meta property="og:title" content="Android P Beta 2, Honor Turbo Charging, and Moto Z3 Play (Episode 11)" />
<meta property="og:url" content="http://www.androidguys.com/2018/06/07/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11/" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Matt and Andrew discuss an update for the Android P Developer Preview, the first smartwatch from fashion designer Marc Jacobs and more! Click here to listen" />
<meta property="og:image" content="http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080.png" />
<meta property="article:published_time" content="2018-06-07T17:00:31+00:00" />
<meta property="article:modified_time" content="2018-06-07T11:56:50+00:00" />
<meta property="og:updated_time" content="2018-06-07T11:56:50+00:00" />
<meta property="article:section" content="Podcast" />

<meta itemprop="name" content="Android P Beta 2, Honor Turbo Charging, and Moto Z3 Play (Episode 11)" />
<meta itemprop="headline" content="Android P Beta 2, Honor Turbo Charging, and Moto Z3 Play (Episode 11)" />
<meta itemprop="description" content="Matt and Andrew discuss an update for the Android P Developer Preview, the first smartwatch from fashion designer Marc Jacobs and more! Click here to listen" />
<meta itemprop="image" content="http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080.png" />
<meta itemprop="datePublished" content="2018-06-07" />
<meta itemprop="dateModified" content="2018-06-07T11:56:50+00:00" />
<meta itemprop="author" content="Matt Adams" />
 

<meta name="twitter:title" content="Android P Beta 2, Honor Turbo Charging, and Moto Z3 Play (Episode 11)" />
<meta name="twitter:url" content="http://www.androidguys.com/2018/06/07/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11/" />
<meta name="twitter:description" content="Matt and Andrew discuss an update for the Android P Developer Preview, the first smartwatch from fashion designer Marc Jacobs and more! Click here to listen" />
<meta name="twitter:image" content="http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080.png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@https://twitter.com/madams1925" />
<meta name="twitter:site" content="@androidguys" />




<script type="8659d7c75a0ee512be482942-">
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2973238-3', 'auto');
  ga('send', 'pageview');

</script>
<script src="https://static.swappa.com/static/widget/widget.min.js" async type="8659d7c75a0ee512be482942-"></script>
<script type="8659d7c75a0ee512be482942-text/javascript" src="//dsh7ky7308k4b.cloudfront.net/publishers/androidguyscom.min.js?v2"></script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js' type="8659d7c75a0ee512be482942-"></script>
<script type="8659d7c75a0ee512be482942-">
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script type="8659d7c75a0ee512be482942-">
  googletag.cmd.push(function() {
    googletag.defineSlot('/8095840/.2_8310.3_androidguys.com_tier1', [728, 90], 'div-gpt-ad-1487237445102-0').addService(googletag.pubads());
    googletag.defineSlot('/8095840/.2_8311.3_androidguys.com_tier1', [728, 90], 'div-gpt-ad-1487237518325-0').addService(googletag.pubads());
	googletag.defineSlot('/8095840/.2_8314.4_androidguys.com_tier1', [300, 250], 'div-gpt-ad-1487237631062-0').addService(googletag.pubads());
    googletag.defineSlot('/8095840/.2_8316.5_androidguys.com_tier1', [320, 50], 'div-gpt-ad-1487238610891-0').addService(googletag.pubads());
    googletag.defineSlot('/8095840/.2_8317.5_androidguys.com_tier1', [320, 50], 'div-gpt-ad-1487238631958-0').addService(googletag.pubads());
    googletag.defineSlot('/8095840/.2_8318.7_androidguys.com_tier1', [300, 600], 'div-gpt-ad-1487256038713-0').addService(googletag.pubads());
    googletag.defineSlot('/8095840/.2_8319.4_androidguys.com_tier1', [300, 250], 'div-gpt-ad-1487238658175-0').addService(googletag.pubads());
    googletag.defineSlot('/8095840/.2_8320.4_androidguys.com_tier1', [300, 250], 'div-gpt-ad-1487238677738-0').addService(googletag.pubads());
    googletag.defineSlot('/8095840/.2_11211.4_androidguys.com_tier1', [300, 250], 'div-gpt-ad-1499250035802-0').addService(googletag.pubads());

    var slot8309 = googletag.defineSlot('/8095840/.2_8309.3_androidguys.com_tier1', [728, 90], 'div-gpt-ad-1487237318659-0').addService(googletag.pubads());
    var slot8312 = googletag.defineSlot('/8095840/.2_8312.7_androidguys.com_tier1', [300, 600], 'div-gpt-ad-1487239195458-0').addService(googletag.pubads());
    var slot8313 = googletag.defineSlot('/8095840/.2_8313.4_androidguys.com_tier1', [300, 250], 'div-gpt-ad-1487237564018-0').addService(googletag.pubads());
    var slot8315 = googletag.defineSlot('/8095840/.2_8315.5_androidguys.com_tier1', [320, 50], 'div-gpt-ad-1487238572908-0').addService(googletag.pubads());

	var refreshSlots = [slot8313, slot8309, slot8312, slot8315];
	setInterval(function() { googletag.pubads().refresh(refreshSlots);}, 60000); 
	googletag.enableServices();
  });
</script>
<meta name="google-site-verification" content="I1ofvKzj9-PCcV8x_fGxRnSAKy1UcgbjbyD-zzQRmZA" />
<script type="8659d7c75a0ee512be482942-text/javascript">
    (function() {
        function async_load(script_url){
            var protocol = ('https:' == document.location.protocol ? 'https://' : 'http://');
            var s = document.createElement('script'); s.src = protocol + script_url;
            var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
        }
        bm_website_code = 'FA8119ABF3BC4F52';
        jQuery(document).ready(function(){async_load('asset.pagefair.com/measure.min.js')});
    })();
</script>
<script type="8659d7c75a0ee512be482942-text/javascript" src="//s.ntv.io/serve/load.js" async></script>
</head>
<body class="post-template-default single single-post postid-139438 single-format-standard android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11 wpb-js-composer js-comp-ver-5.4.2 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.facebook.com/androidguys" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.instagram.com/androidguys" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.androidguys.com/feed/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.twitter.com/androidguys" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-main-navigation-container"><ul id="menu-main-navigation" class="td-mobile-main-menu"><li id="menu-item-79191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-79191"><a href="http://www.androidguys.com/category/news/">News</a></li>
<li id="menu-item-114857" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114857"><a href="http://www.androidguys.com/category/featured/deal-of-day-stack-commerce/">Deals</a></li>
<li id="menu-item-101200" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-101200"><a href="http://www.androidguys.com/category/reviews/">Reviews<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><a href="http://www.androidguys.com/category/reviews/accessory-reviews/">Accessory Reviews</a></li>
<li class="menu-item-0"><a href="http://www.androidguys.com/category/reviews/software-reviews/">App &amp; Game Reviews</a></li>
<li class="menu-item-0"><a href="http://www.androidguys.com/category/reviews/software-reviews/app-game-roundups/">App &amp; Game Roundups</a></li>
<li class="menu-item-0"><a href="http://www.androidguys.com/category/reviews/hardware-reviews/">Hardware Reviews</a></li>
<li class="menu-item-0"><a href="http://www.androidguys.com/category/reviews/smartphone-reviews/">Smartphone Reviews</a></li>
</ul>
</li>
<li id="menu-item-79194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79194"><a href="http://www.androidguys.com/category/tips-tricks/">Tips &#038; Tools</a></li>
<li id="menu-item-133384" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-133384"><a href="http://www.androidguys.com/category/best/">Best</a></li>
<li id="menu-item-101731" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-101731"><a href="http://www.androidguys.com/category/featured/">Featured<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-114860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114860"><a href="http://www.androidguys.com/category/featured/editorials-and-opinions/">Editorials and Opinions</a></li>
<li id="menu-item-114859" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114859"><a href="http://www.androidguys.com/category/featured/customization/">Customization</a></li>
<li id="menu-item-122685" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122685"><a href="http://www.androidguys.com/category/community/">Community Contributions</a></li>
<li id="menu-item-125538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-125538"><a href="http://www.androidguys.com/category/promoted-deals/">Promoted Deals</a></li>
<li id="menu-item-114861" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114861"><a href="http://www.androidguys.com/category/featured/smartphone-showdowns/">Smartphone Showdowns</a></li>
<li id="menu-item-114862" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114862"><a href="http://www.androidguys.com/category/featured/wallpapers/">Wallpapers</a></li>
</ul>
</li>
<li id="menu-item-112029" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-112029"><a href="http://www.androidguys.com/buyers-guides/">Guides<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-112037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112037"><a href="http://www.androidguys.com/buyers-guide-headphones-earbuds/">Headphones &#038; Earbuds</a></li>
<li id="menu-item-112038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112038"><a href="http://www.androidguys.com/buyers-guide-unlocked-smartphones/">Unlocked Smartphones</a></li>
<li id="menu-item-112036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112036"><a href="http://www.androidguys.com/buyers-guide-prepaid-carriers/">Prepaid Carriers</a></li>
<li id="menu-item-112948" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112948"><a href="http://www.androidguys.com/buyers-guide-mvnos/">MVNOs</a></li>
<li id="menu-item-112039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112039"><a href="http://www.androidguys.com/buyers-guide-bluetooth-speakers/">Bluetooth Speakers</a></li>
</ul>
</li>
<li id="menu-item-138839" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-138839"><a href="http://www.androidguys.com/category/podcast/">Podcast</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="http://www.androidguys.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap">

<div class="td-header-wrap td-header-style-3">
<div class="td-header-top-menu-full">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-4">
<div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.facebook.com/androidguys" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.instagram.com/androidguys" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.androidguys.com/feed/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.twitter.com/androidguys" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div>
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-follow-us" class="top-header-menu"><li id="menu-item-117019" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-117019"><a href="http://deals.androidguys.com">Shop Great Deals</a></li>
<li id="menu-item-110042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-110042"><a href="http://www.androidguys.com/contact/">Contact</a>
<ul class="sub-menu">
<li id="menu-item-134342" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-134342"><a href="http://www.androidguys.com/request-app-review/">Request App or Game Review</a></li>
<li id="menu-item-110044" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-110044"><a href="http://www.androidguys.com/sponsorship-opportunities/">Advertising and Sponsorship</a></li>
<li id="menu-item-110043" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-110043"><a href="http://www.androidguys.com/sponsored-review/">Sponsored App Reviews</a></li>
<li id="menu-item-124421" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-124421"><a href="http://www.androidguys.com/sponsored-product-review/">Sponsored Product Review</a></li>
</ul>
</li>
<li id="menu-item-133383" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-133383"><a href="http://www.androidguys.com/category/featured/giveaways/">Giveaways</a></li>
<li id="menu-item-110048" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-110048"><a href="http://www.androidguys.com/about/">About</a></li>
<li id="menu-item-119705" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-119705"><a href="http://www.androidguys.com/jobs/">Jobs</a></li>
</ul></div></div>
</div>

</div>
</div>
<div class="td-banner-wrap-full">
<div class="td-container td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="http://www.androidguys.com/">
<img class="td-retina-data" data-retina="http://www.androidguys.com/wp-content/uploads/2017/03/ag_logo_544_180.png" src="http://www.androidguys.com/wp-content/uploads/2017/03/ag_logo_270_90_android.png" alt="AndroidGuys" />
<span class="td-visual-hidden">AndroidGuys</span>
</a>
</div>
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">
<div class="td-a-rec td-a-rec-id-header  "><div class="td-visible-desktop">
<div id='div-gpt-ad-1487237318659-0' style='height:90px; width:728px;'>
<script type="8659d7c75a0ee512be482942-">googletag.cmd.push(function () {googletag.display('div-gpt-ad-1487237318659-0');});</script>
</div>
</div>
<div class="td-visible-phone">
<div id='div-gpt-ad-1487238572908-0' style='height:50px; width:320px;'>
<script type="8659d7c75a0ee512be482942-">googletag.cmd.push(function() { googletag.display('div-gpt-ad-1487238572908-0'); });</script>
</div>
</div>
</div>
</div> </div>
</div>
</div>
<div class="td-header-menu-wrap-full">
<div class="td-header-menu-wrap">
<div class="td-container td-header-row td-header-main-menu black-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-disable" href="http://www.androidguys.com/">
<img class="td-retina-data" data-retina="http://www.androidguys.com/wp-content/uploads/2016/03/ag_280_96.png" src="http://www.androidguys.com/wp-content/uploads/2016/03/ag_140_48.png" alt="AndroidGuys" />
</a>
<a class="td-header-logo td-sticky-disable" href="http://www.androidguys.com/">
<img class="td-retina-data" data-retina="http://www.androidguys.com/wp-content/uploads/2017/03/ag_logo_544_180.png" src="http://www.androidguys.com/wp-content/uploads/2017/03/ag_logo_270_90_android.png" alt="AndroidGuys" />
</a>
</div>
<div class="menu-main-navigation-container"><ul id="menu-main-navigation-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-79191"><a href="http://www.androidguys.com/category/news/">News</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5b199cf4c3bcd_rand td-no-subcats td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_2_5b199cf4c3bcd"><script type="8659d7c75a0ee512be482942-">var block_td_uid_2_5b199cf4c3bcd = new tdBlock();
block_td_uid_2_5b199cf4c3bcd.id = "td_uid_2_5b199cf4c3bcd";
block_td_uid_2_5b199cf4c3bcd.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"5","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5b199cf4c3bcd_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_2_5b199cf4c3bcd_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5b199cf4c3bcd.td_column_number = "3";
block_td_uid_2_5b199cf4c3bcd.block_type = "td_block_mega_menu";
block_td_uid_2_5b199cf4c3bcd.post_count = "5";
block_td_uid_2_5b199cf4c3bcd.found_posts = "19082";
block_td_uid_2_5b199cf4c3bcd.header_color = "";
block_td_uid_2_5b199cf4c3bcd.ajax_pagination_infinite_stop = "";
block_td_uid_2_5b199cf4c3bcd.max_num_pages = "3817";
tdBlocksArray.push(block_td_uid_2_5b199cf4c3bcd);
</script><div id=td_uid_2_5b199cf4c3bcd class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/07/google-congress-huawei-privacy/" rel="bookmark" title="Congress scrutinizes Google&#8217;s deal with Huawei over privacy concerns"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2017/08/Google-Headquarters-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2017/08/Google-Headquarters-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2017/08/Google-Headquarters-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Congress scrutinizes Google&#8217;s deal with Huawei over privacy concerns" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/07/google-congress-huawei-privacy/" rel="bookmark" title="Congress scrutinizes Google&#8217;s deal with Huawei over privacy concerns">Congress scrutinizes Google&#8217;s deal with Huawei over privacy concerns</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/07/amazon-fire-tv-cube-launched/" rel="bookmark" title="Meet Amazon’s latest Alexa-powered device, the Fire TV Cube"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/Amazon-Fire-TV-Cube-3-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/Amazon-Fire-TV-Cube-3-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/06/Amazon-Fire-TV-Cube-3-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Meet Amazon’s latest Alexa-powered device, the Fire TV Cube" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/07/amazon-fire-tv-cube-launched/" rel="bookmark" title="Meet Amazon’s latest Alexa-powered device, the Fire TV Cube">Meet Amazon’s latest Alexa-powered device, the Fire TV Cube</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/07/blackberry-key2-official/" rel="bookmark" title="BlackBerry KEY2 is official with refined design, dual-camera setup"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/Main-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/Main-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/06/Main-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="BlackBerry KEY2 is official with refined design, dual-camera setup" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/07/blackberry-key2-official/" rel="bookmark" title="BlackBerry KEY2 is official with refined design, dual-camera setup">BlackBerry KEY2 is official with refined design, dual-camera setup</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/07/textnow-unlimited-lte-plan/" rel="bookmark" title="TextNow unveils super affordable unlimited LTE plan for $39.99/month"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/TextMe-Unlimited-Data-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/TextMe-Unlimited-Data-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/06/TextMe-Unlimited-Data-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="TextNow unveils super affordable unlimited LTE plan for $39.99/month" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/07/textnow-unlimited-lte-plan/" rel="bookmark" title="TextNow unveils super affordable unlimited LTE plan for $39.99/month">TextNow unveils super affordable unlimited LTE plan for $39.99/month</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/07/android-p-beta-2-pixel/" rel="bookmark" title="Android P beta 2 is now out, available for Pixel owners"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/Android-P-Logo-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/Android-P-Logo-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/06/Android-P-Logo-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Android P beta 2 is now out, available for Pixel owners" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/07/android-p-beta-2-pixel/" rel="bookmark" title="Android P beta 2 is now out, available for Pixel owners">Android P beta 2 is now out, available for Pixel owners</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5b199cf4c3bcd" data-td_block_id="td_uid_2_5b199cf4c3bcd"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_2_5b199cf4c3bcd" data-td_block_id="td_uid_2_5b199cf4c3bcd"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-114857"><a href="http://www.androidguys.com/category/featured/deal-of-day-stack-commerce/">Deals</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5b199cf4d1458_rand td-no-subcats td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_3_5b199cf4d1458"><script type="8659d7c75a0ee512be482942-">var block_td_uid_3_5b199cf4d1458 = new tdBlock();
block_td_uid_3_5b199cf4d1458.id = "td_uid_3_5b199cf4d1458";
block_td_uid_3_5b199cf4d1458.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"30058","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5b199cf4d1458_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_3_5b199cf4d1458_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5b199cf4d1458.td_column_number = "3";
block_td_uid_3_5b199cf4d1458.block_type = "td_block_mega_menu";
block_td_uid_3_5b199cf4d1458.post_count = "5";
block_td_uid_3_5b199cf4d1458.found_posts = "648";
block_td_uid_3_5b199cf4d1458.header_color = "";
block_td_uid_3_5b199cf4d1458.ajax_pagination_infinite_stop = "";
block_td_uid_3_5b199cf4d1458.max_num_pages = "130";
tdBlocksArray.push(block_td_uid_3_5b199cf4d1458);
</script><div id=td_uid_3_5b199cf4d1458 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/06/microsoft-excel-master-certification/" rel="bookmark" title="Become an Excel whiz with this $39 certification bundle"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/excel_background-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/excel_background-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/05/excel_background-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Become an Excel whiz with this $39 certification bundle" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/06/microsoft-excel-master-certification/" rel="bookmark" title="Become an Excel whiz with this $39 certification bundle">Become an Excel whiz with this $39 certification bundle</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/05/3-in-1-fast-wireless-charging-pad/" rel="bookmark" title="Charge three devices at once with iPM 3-in-1 Fast Wireless Charging Pad, just $48.99"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/3-in-1-wireless-charger-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/3-in-1-wireless-charger-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/06/3-in-1-wireless-charger-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Charge three devices at once with iPM 3-in-1 Fast Wireless Charging Pad, just $48.99" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/05/3-in-1-fast-wireless-charging-pad/" rel="bookmark" title="Charge three devices at once with iPM 3-in-1 Fast Wireless Charging Pad, just $48.99">Charge three devices at once with iPM 3-in-1 Fast Wireless Charging&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/04/ipm-world-wireless-security-camera/" rel="bookmark" title="iPM World HD 360 Degree 1080p wireless IP camera: Panoramic security for just $44.99"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/ipm_world_camera-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/ipm_world_camera-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/06/ipm_world_camera-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="iPM World HD 360 Degree 1080p wireless IP camera: Panoramic security for just $44.99" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/04/ipm-world-wireless-security-camera/" rel="bookmark" title="iPM World HD 360 Degree 1080p wireless IP camera: Panoramic security for just $44.99">iPM World HD 360 Degree 1080p wireless IP camera: Panoramic security&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/01/master-excel-bootcamp-training/" rel="bookmark" title="Learn to manipulate data like a pro with the $49 Ultimate Excel Bootcamp Bundle"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/01/Business-Analysis-Microsoft-Excel-218x150.png" srcset="http://www.androidguys.com/wp-content/uploads/2018/01/Business-Analysis-Microsoft-Excel-218x150.png 218w, http://www.androidguys.com/wp-content/uploads/2018/01/Business-Analysis-Microsoft-Excel-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Learn to manipulate data like a pro with the $49 Ultimate Excel Bootcamp Bundle" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/01/master-excel-bootcamp-training/" rel="bookmark" title="Learn to manipulate data like a pro with the $49 Ultimate Excel Bootcamp Bundle">Learn to manipulate data like a pro with the $49 Ultimate&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/31/lifetime-ivacy-vpn-discount/" rel="bookmark" title="A lifetime of Ivacy VPN can be yours for just $39.99"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/ivacy_vpn-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/ivacy_vpn-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/05/ivacy_vpn-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="A lifetime of Ivacy VPN can be yours for just $39.99" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/31/lifetime-ivacy-vpn-discount/" rel="bookmark" title="A lifetime of Ivacy VPN can be yours for just $39.99">A lifetime of Ivacy VPN can be yours for just $39.99</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5b199cf4d1458" data-td_block_id="td_uid_3_5b199cf4d1458"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_3_5b199cf4d1458" data-td_block_id="td_uid_3_5b199cf4d1458"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-101200"><a href="http://www.androidguys.com/category/reviews/">Reviews</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5b199cf4e04ac_rand td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_4_5b199cf4e04ac"><script type="8659d7c75a0ee512be482942-">var block_td_uid_4_5b199cf4e04ac = new tdBlock();
block_td_uid_4_5b199cf4e04ac.id = "td_uid_4_5b199cf4e04ac";
block_td_uid_4_5b199cf4e04ac.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"27951","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5b199cf4e04ac_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_4_5b199cf4e04ac_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5b199cf4e04ac.td_column_number = "3";
block_td_uid_4_5b199cf4e04ac.block_type = "td_block_mega_menu";
block_td_uid_4_5b199cf4e04ac.post_count = "4";
block_td_uid_4_5b199cf4e04ac.found_posts = "2399";
block_td_uid_4_5b199cf4e04ac.header_color = "";
block_td_uid_4_5b199cf4e04ac.ajax_pagination_infinite_stop = "";
block_td_uid_4_5b199cf4e04ac.max_num_pages = "600";
tdBlocksArray.push(block_td_uid_4_5b199cf4e04ac);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5b199cf4e04ac" id="td_uid_5_5b199cf4e5a6b" data-td_block_id="td_uid_4_5b199cf4e04ac" data-td_filter_value="" href="http://www.androidguys.com/category/reviews/">All</a><a class="mega-menu-sub-cat-td_uid_4_5b199cf4e04ac" id="td_uid_6_5b199cf4e5bed" data-td_block_id="td_uid_4_5b199cf4e04ac" data-td_filter_value="16" href="http://www.androidguys.com/category/reviews/accessory-reviews/">Accessory Reviews</a><a class="mega-menu-sub-cat-td_uid_4_5b199cf4e04ac" id="td_uid_7_5b199cf4e5d6f" data-td_block_id="td_uid_4_5b199cf4e04ac" data-td_filter_value="27952" href="http://www.androidguys.com/category/reviews/software-reviews/">App &amp; Game Reviews</a><a class="mega-menu-sub-cat-td_uid_4_5b199cf4e04ac" id="td_uid_8_5b199cf4e5e8b" data-td_block_id="td_uid_4_5b199cf4e04ac" data-td_filter_value="36125" href="http://www.androidguys.com/category/reviews/software-reviews/app-game-roundups/">App &amp; Game Roundups</a><a class="mega-menu-sub-cat-td_uid_4_5b199cf4e04ac" id="td_uid_9_5b199cf4e5ff0" data-td_block_id="td_uid_4_5b199cf4e04ac" data-td_filter_value="2816" href="http://www.androidguys.com/category/reviews/hardware-reviews/">Hardware Reviews</a><a class="mega-menu-sub-cat-td_uid_4_5b199cf4e04ac" id="td_uid_10_5b199cf4e6132" data-td_block_id="td_uid_4_5b199cf4e04ac" data-td_filter_value="28927" href="http://www.androidguys.com/category/reviews/smartphone-reviews/">Smartphone Reviews</a></div></div><div id=td_uid_4_5b199cf4e04ac class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/07/huawei-watch-2-classic-review/" rel="bookmark" title="HUAWEI Watch 2 Classic Review"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/HUAWEI-Watch-2-Classic-1-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/HUAWEI-Watch-2-Classic-1-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/06/HUAWEI-Watch-2-Classic-1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="HUAWEI Watch 2 Classic Review" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/07/huawei-watch-2-classic-review/" rel="bookmark" title="HUAWEI Watch 2 Classic Review">HUAWEI Watch 2 Classic Review</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/06/choetech-fast-wireless-charger-review/" rel="bookmark" title="Choetech fast wireless charger review: Substance over style"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/choetech_wireless_charger_review_03-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/choetech_wireless_charger_review_03-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/06/choetech_wireless_charger_review_03-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Choetech fast wireless charger review: Substance over style" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/06/choetech-fast-wireless-charger-review/" rel="bookmark" title="Choetech fast wireless charger review: Substance over style">Choetech fast wireless charger review: Substance over style</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/05/optoma-nuforce-free5-earbuds-review/" rel="bookmark" title="Optoma NuForce BE Free5 True Wireless Earbuds Review &#8211; Refined and lower in price"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/Optoma-NuForce-Be-Free5-10-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/Optoma-NuForce-Be-Free5-10-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/06/Optoma-NuForce-Be-Free5-10-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Optoma NuForce BE Free5 Earbuds" title="Optoma NuForce BE Free5 True Wireless Earbuds Review &#8211; Refined and lower in price" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/05/optoma-nuforce-free5-earbuds-review/" rel="bookmark" title="Optoma NuForce BE Free5 True Wireless Earbuds Review &#8211; Refined and lower in price">Optoma NuForce BE Free5 True Wireless Earbuds Review &#8211; Refined and&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
 <div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/04/games-under-25mb-for-android/" rel="bookmark" title="Low on storage? Check out these ten best games under 25MB for Android"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/Mega-Worm-Mode-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/Mega-Worm-Mode-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/05/Mega-Worm-Mode-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Low on storage? Check out these ten best games under 25MB for Android" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/04/games-under-25mb-for-android/" rel="bookmark" title="Low on storage? Check out these ten best games under 25MB for Android">Low on storage? Check out these ten best games under 25MB&#8230;</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5b199cf4e04ac" data-td_block_id="td_uid_4_5b199cf4e04ac"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_4_5b199cf4e04ac" data-td_block_id="td_uid_4_5b199cf4e04ac"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-79194"><a href="http://www.androidguys.com/category/tips-tricks/">Tips &#038; Tools</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5b199cf4ea14d_rand td-no-subcats td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_11_5b199cf4ea14d"><script type="8659d7c75a0ee512be482942-">var block_td_uid_11_5b199cf4ea14d = new tdBlock();
block_td_uid_11_5b199cf4ea14d.id = "td_uid_11_5b199cf4ea14d";
block_td_uid_11_5b199cf4ea14d.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"19360","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5b199cf4ea14d_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_11_5b199cf4ea14d_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5b199cf4ea14d.td_column_number = "3";
block_td_uid_11_5b199cf4ea14d.block_type = "td_block_mega_menu";
block_td_uid_11_5b199cf4ea14d.post_count = "5";
block_td_uid_11_5b199cf4ea14d.found_posts = "463";
block_td_uid_11_5b199cf4ea14d.header_color = "";
block_td_uid_11_5b199cf4ea14d.ajax_pagination_infinite_stop = "";
block_td_uid_11_5b199cf4ea14d.max_num_pages = "93";
tdBlocksArray.push(block_td_uid_11_5b199cf4ea14d);
</script><div id=td_uid_11_5b199cf4ea14d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/06/improve-call-quality-android-phone/" rel="bookmark" title="How to improve call quality on your Android phone"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/Talking-on-Smartphone-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/Talking-on-Smartphone-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/05/Talking-on-Smartphone-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="How to improve call quality on your Android phone" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/06/improve-call-quality-android-phone/" rel="bookmark" title="How to improve call quality on your Android phone">How to improve call quality on your Android phone</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/04/stop-android-apps-automatically-updating/" rel="bookmark" title="How to stop apps from automatically updating"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/Snapchat-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/Snapchat-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/05/Snapchat-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="How to stop apps from automatically updating" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/04/stop-android-apps-automatically-updating/" rel="bookmark" title="How to stop apps from automatically updating">How to stop apps from automatically updating</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/02/how-to-unlock-samsung-galaxy-s9-everything-you-need-to-know/" rel="bookmark" title="How to unlock Samsung Galaxy S9 &#8211; Everything you need to know"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/New-Galaxy-S9-Colors-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/New-Galaxy-S9-Colors-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/05/New-Galaxy-S9-Colors-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="How to unlock Samsung Galaxy S9 &#8211; Everything you need to know" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/02/how-to-unlock-samsung-galaxy-s9-everything-you-need-to-know/" rel="bookmark" title="How to unlock Samsung Galaxy S9 &#8211; Everything you need to know">How to unlock Samsung Galaxy S9 &#8211; Everything you need to&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/22/add-trusted-place-android-smart-lock/" rel="bookmark" title="How to add a Trusted Place to Android Smart Lock"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/trusted_place-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/trusted_place-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/05/trusted_place-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="How to add a Trusted Place to Android Smart Lock" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/22/add-trusted-place-android-smart-lock/" rel="bookmark" title="How to add a Trusted Place to Android Smart Lock">How to add a Trusted Place to Android Smart Lock</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/12/enable-gmail-smart-compose/" rel="bookmark" title="How to enable Google&#8217;s new Smart Compose feature in Gmail"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/Gmail-218x150.gif" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/Gmail-218x150.gif 218w, http://www.androidguys.com/wp-content/uploads/2018/05/Gmail-100x70.gif 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="How to enable Google&#8217;s new Smart Compose feature in Gmail" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/12/enable-gmail-smart-compose/" rel="bookmark" title="How to enable Google&#8217;s new Smart Compose feature in Gmail">How to enable Google&#8217;s new Smart Compose feature in Gmail</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5b199cf4ea14d" data-td_block_id="td_uid_11_5b199cf4ea14d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_11_5b199cf4ea14d" data-td_block_id="td_uid_11_5b199cf4ea14d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-133384"><a href="http://www.androidguys.com/category/best/">Best</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_12_5b199cf4f1de8_rand td-no-subcats td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_12_5b199cf4f1de8"><script type="8659d7c75a0ee512be482942-">var block_td_uid_12_5b199cf4f1de8 = new tdBlock();
block_td_uid_12_5b199cf4f1de8.id = "td_uid_12_5b199cf4f1de8";
block_td_uid_12_5b199cf4f1de8.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"36116","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_12_5b199cf4f1de8_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_12_5b199cf4f1de8_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_12_5b199cf4f1de8.td_column_number = "3";
block_td_uid_12_5b199cf4f1de8.block_type = "td_block_mega_menu";
block_td_uid_12_5b199cf4f1de8.post_count = "5";
block_td_uid_12_5b199cf4f1de8.found_posts = "25";
block_td_uid_12_5b199cf4f1de8.header_color = "";
block_td_uid_12_5b199cf4f1de8.ajax_pagination_infinite_stop = "";
block_td_uid_12_5b199cf4f1de8.max_num_pages = "5";
tdBlocksArray.push(block_td_uid_12_5b199cf4f1de8);
</script><div id=td_uid_12_5b199cf4f1de8 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/06/best-android-smartphones-flagships-june-2018-2/" rel="bookmark" title="The five best Android smartphones you can buy right now (June 2018)"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/01/OnePlus-5T-App-Drawer-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/01/OnePlus-5T-App-Drawer-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/01/OnePlus-5T-App-Drawer-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="The five best Android smartphones you can buy right now (June 2018)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/06/best-android-smartphones-flagships-june-2018-2/" rel="bookmark" title="The five best Android smartphones you can buy right now (June 2018)">The five best Android smartphones you can buy right now (June&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/25/best-android-phones-for-gaming-may-2018/" rel="bookmark" title="These are the best best Android phones for gaming (May 2018)"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/01/razer_phone_speaker-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/01/razer_phone_speaker-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/01/razer_phone_speaker-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="These are the best best Android phones for gaming (May 2018)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/25/best-android-phones-for-gaming-may-2018/" rel="bookmark" title="These are the best best Android phones for gaming (May 2018)">These are the best best Android phones for gaming (May 2018)</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/18/best-budget-android-smartphones-may-2018/" rel="bookmark" title="The five best budget Android smartphones you can buy right now (May 2018)"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/02/Essential-Phone-3-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/02/Essential-Phone-3-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/02/Essential-Phone-3-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="The five best budget Android smartphones you can buy right now (May 2018)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/18/best-budget-android-smartphones-may-2018/" rel="bookmark" title="The five best budget Android smartphones you can buy right now (May 2018)">The five best budget Android smartphones you can buy right now&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/17/best-phones-sprint-may-2018/" rel="bookmark" title="The best phones you can buy at Sprint right now (May 2018)"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2017/04/Sprint-1-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2017/04/Sprint-1-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2017/04/Sprint-1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="The best phones you can buy at Sprint right now (May 2018)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/17/best-phones-sprint-may-2018/" rel="bookmark" title="The best phones you can buy at Sprint right now (May 2018)">The best phones you can buy at Sprint right now (May&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/16/best-chinese-phones-may-2018/" rel="bookmark" title="Best Chinese phones you can buy right now (May 2018)"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2017/10/Huawei-Mate-10-Pro-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2017/10/Huawei-Mate-10-Pro-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2017/10/Huawei-Mate-10-Pro-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Best Chinese phones you can buy right now (May 2018)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/16/best-chinese-phones-may-2018/" rel="bookmark" title="Best Chinese phones you can buy right now (May 2018)">Best Chinese phones you can buy right now (May 2018)</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_12_5b199cf4f1de8" data-td_block_id="td_uid_12_5b199cf4f1de8"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_12_5b199cf4f1de8" data-td_block_id="td_uid_12_5b199cf4f1de8"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-mega-menu menu-item-101731"><a href="http://www.androidguys.com/category/featured/">Featured</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_13_5b199cf505c00_rand td-no-subcats td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_13_5b199cf505c00"><script type="8659d7c75a0ee512be482942-">var block_td_uid_13_5b199cf505c00 = new tdBlock();
block_td_uid_13_5b199cf505c00.id = "td_uid_13_5b199cf505c00";
block_td_uid_13_5b199cf505c00.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"32798","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_13_5b199cf505c00_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_13_5b199cf505c00_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_13_5b199cf505c00.td_column_number = "3";
block_td_uid_13_5b199cf505c00.block_type = "td_block_mega_menu";
block_td_uid_13_5b199cf505c00.post_count = "5";
block_td_uid_13_5b199cf505c00.found_posts = "73";
block_td_uid_13_5b199cf505c00.header_color = "";
block_td_uid_13_5b199cf505c00.ajax_pagination_infinite_stop = "";
block_td_uid_13_5b199cf505c00.max_num_pages = "15";
tdBlocksArray.push(block_td_uid_13_5b199cf505c00);
</script><div id=td_uid_13_5b199cf505c00 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/23/htc-u12-vs-htc-u11-upgrade/" rel="bookmark" title="HTC U12+ vs HTC U11: Should I upgrade?"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/should_i_upgrade_htc_u12-rev2-218x150.png" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/should_i_upgrade_htc_u12-rev2-218x150.png 218w, http://www.androidguys.com/wp-content/uploads/2018/05/should_i_upgrade_htc_u12-rev2-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="HTC U12+ vs HTC U11: Should I upgrade?" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/23/htc-u12-vs-htc-u11-upgrade/" rel="bookmark" title="HTC U12+ vs HTC U11: Should I upgrade?">HTC U12+ vs HTC U11: Should I upgrade?</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/23/oneplus-6-vs-lg-g7-thinq/" rel="bookmark" title="What&#8217;s the difference: OnePlus 6 vs LG G7 ThinQ"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/smartphone_showdown_template_test_2-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/smartphone_showdown_template_test_2-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/05/smartphone_showdown_template_test_2-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="What&#8217;s the difference: OnePlus 6 vs LG G7 ThinQ" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/23/oneplus-6-vs-lg-g7-thinq/" rel="bookmark" title="What&#8217;s the difference: OnePlus 6 vs LG G7 ThinQ">What&#8217;s the difference: OnePlus 6 vs LG G7 ThinQ</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/21/honor-10-vs-oneplus-6/" rel="bookmark" title="Affordable flagships battle it out: Honor 10 vs OnePlus 6"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/Honor-10-1-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/Honor-10-1-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/05/Honor-10-1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Affordable flagships battle it out: Honor 10 vs OnePlus 6" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/21/honor-10-vs-oneplus-6/" rel="bookmark" title="Affordable flagships battle it out: Honor 10 vs OnePlus 6">Affordable flagships battle it out: Honor 10 vs OnePlus 6</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/16/oneplus-6-vs-galaxy-s9/" rel="bookmark" title="What&#8217;s the difference: OnePlus 6 versus Samsung Galaxy S9"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/OP6-vs-S9-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/OP6-vs-S9-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/05/OP6-vs-S9-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="What&#8217;s the difference: OnePlus 6 versus Samsung Galaxy S9" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/16/oneplus-6-vs-galaxy-s9/" rel="bookmark" title="What&#8217;s the difference: OnePlus 6 versus Samsung Galaxy S9">What&#8217;s the difference: OnePlus 6 versus Samsung Galaxy S9</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/02/lg-g7-thinq-vs-lg-g6/" rel="bookmark" title="What’s the difference: LG G7 ThinQ vs LG G6"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/LG-G7-ThinQ-4-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/LG-G7-ThinQ-4-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/05/LG-G7-ThinQ-4-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="What’s the difference: LG G7 ThinQ vs LG G6" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/02/lg-g7-thinq-vs-lg-g6/" rel="bookmark" title="What’s the difference: LG G7 ThinQ vs LG G6">What’s the difference: LG G7 ThinQ vs LG G6</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_13_5b199cf505c00" data-td_block_id="td_uid_13_5b199cf505c00"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_13_5b199cf505c00" data-td_block_id="td_uid_13_5b199cf505c00"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-114860"><a href="http://www.androidguys.com/category/featured/editorials-and-opinions/">Editorials and Opinions</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-114859"><a href="http://www.androidguys.com/category/featured/customization/">Customization</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-122685"><a href="http://www.androidguys.com/category/community/">Community Contributions</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-125538"><a href="http://www.androidguys.com/category/promoted-deals/">Promoted Deals</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-114861"><a href="http://www.androidguys.com/category/featured/smartphone-showdowns/">Smartphone Showdowns</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-114862"><a href="http://www.androidguys.com/category/featured/wallpapers/">Wallpapers</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-112029"><a href="http://www.androidguys.com/buyers-guides/">Guides</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-112037"><a href="http://www.androidguys.com/buyers-guide-headphones-earbuds/">Headphones &#038; Earbuds</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-112038"><a href="http://www.androidguys.com/buyers-guide-unlocked-smartphones/">Unlocked Smartphones</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-112036"><a href="http://www.androidguys.com/buyers-guide-prepaid-carriers/">Prepaid Carriers</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-112948"><a href="http://www.androidguys.com/buyers-guide-mvnos/">MVNOs</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-112039"><a href="http://www.androidguys.com/buyers-guide-bluetooth-speakers/">Bluetooth Speakers</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-138839"><a href="http://www.androidguys.com/category/podcast/">Podcast</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_14_5b199cf50d74b_rand td-no-subcats td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_14_5b199cf50d74b"><script type="8659d7c75a0ee512be482942-">var block_td_uid_14_5b199cf50d74b = new tdBlock();
block_td_uid_14_5b199cf50d74b.id = "td_uid_14_5b199cf50d74b";
block_td_uid_14_5b199cf50d74b.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"36610","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_14_5b199cf50d74b_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_14_5b199cf50d74b_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_14_5b199cf50d74b.td_column_number = "3";
block_td_uid_14_5b199cf50d74b.block_type = "td_block_mega_menu";
block_td_uid_14_5b199cf50d74b.post_count = "5";
block_td_uid_14_5b199cf50d74b.found_posts = "11";
block_td_uid_14_5b199cf50d74b.header_color = "";
block_td_uid_14_5b199cf50d74b.ajax_pagination_infinite_stop = "";
block_td_uid_14_5b199cf50d74b.max_num_pages = "3";
tdBlocksArray.push(block_td_uid_14_5b199cf50d74b);
</script><div id=td_uid_14_5b199cf50d74b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/07/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11/" rel="bookmark" title="Android P Beta 2, Honor Turbo Charging, and Moto Z3 Play (Episode 11)"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080-218x150.png" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080-218x150.png 218w, http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Android P Beta 2, Honor Turbo Charging, and Moto Z3 Play (Episode 11)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/07/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11/" rel="bookmark" title="Android P Beta 2, Honor Turbo Charging, and Moto Z3 Play (Episode 11)">Android P Beta 2, Honor Turbo Charging, and Moto Z3 Play&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/07/blackberry-key-2/" rel="bookmark" title="Hot Take: BlackBerry Key2 (Episode 12)"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/key2trio-218x150.png" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/key2trio-218x150.png 218w, http://www.androidguys.com/wp-content/uploads/2018/06/key2trio-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Hot Take: BlackBerry Key2 (Episode 12)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/07/blackberry-key-2/" rel="bookmark" title="Hot Take: BlackBerry Key2 (Episode 12)">Hot Take: BlackBerry Key2 (Episode 12)</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/05/android-patches-google-lens-gaming-phones/" rel="bookmark" title="Android Patches, Google Lens, and Gaming Phones (Episode 10)"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/ASUS-ROG-Phone-Extra-3-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/ASUS-ROG-Phone-Extra-3-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/06/ASUS-ROG-Phone-Extra-3-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Android Patches, Google Lens, and Gaming Phones (Episode 10)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/05/android-patches-google-lens-gaming-phones/" rel="bookmark" title="Android Patches, Google Lens, and Gaming Phones (Episode 10)">Android Patches, Google Lens, and Gaming Phones (Episode 10)</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/30/hot-take-lg-v35-thinq/" rel="bookmark" title="Hot Take: LG V35 ThinQ (Episode 8)"><img width="1" height="1" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/lv_v35_thinq-wide.jpg" alt="" title="Hot Take: LG V35 ThinQ (Episode 8)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/30/hot-take-lg-v35-thinq/" rel="bookmark" title="Hot Take: LG V35 ThinQ (Episode 8)">Hot Take: LG V35 ThinQ (Episode 8)</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/24/youtube-music-google-home-google-lens/" rel="bookmark" title="YouTube Music, Google Home, and Google Lens (Episode 7)"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/ytmusic-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/05/ytmusic-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/05/ytmusic-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="YouTube Music, Google Home, and Google Lens (Episode 7)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/24/youtube-music-google-home-google-lens/" rel="bookmark" title="YouTube Music, Google Home, and Google Lens (Episode 7)">YouTube Music, Google Home, and Google Lens (Episode 7)</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_14_5b199cf50d74b" data-td_block_id="td_uid_14_5b199cf50d74b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_14_5b199cf50d74b" data-td_block_id="td_uid_14_5b199cf50d74b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="http://www.androidguys.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div> </div>
</div>
</div>
</div><div class="td-main-content-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"><div class="entry-crumbs" itemscope itemtype="http://schema.org/BreadcrumbList"><span class="td-bred-first"><a href="http://www.androidguys.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemprop="itemListElement" itemtype="http://schema.org/ListItem">
<a title="View all posts in Podcast" class="entry-crumb" itemscope itemprop="item" itemtype="http://schema.org/Thing" href="http://www.androidguys.com/category/podcast/">
<span itemprop="name">Podcast</span> </a> <meta itemprop="position" content="1"></span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-139438" class="post-139438 post type-post status-publish format-standard has-post-thumbnail hentry category-podcast tag-android-p-developer-preview tag-honor tag-honor-10 tag-honor-7x tag-honor-9-lite tag-honor-view-10 tag-marc-jacobs tag-marc-jacobs-riley-touchscreen tag-motorola tag-motorola-moto-z3-play" itemscope itemtype="http://schema.org/Article">
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a href="http://www.androidguys.com/category/podcast/">Podcast</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">Android P Beta 2, Honor Turbo Charging, and Moto Z3 Play (Episode 11)</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="http://www.androidguys.com/author/matt-adams/">Matt Adams</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-06-07T17:00:31+00:00">June 7, 2018</time></span> </div>
</header>
</div>
<div class="td-post-sharing td-post-sharing-top ">
<div class="td-default-sharing">
<a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.androidguys.com%2F2018%2F06%2F07%2Fandroid-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a>
<a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Android+P+Beta+2%2C+Honor+Turbo+Charging%2C+and+Moto+Z3+Play+%28Episode+11%29&url=http%3A%2F%2Fwww.androidguys.com%2F2018%2F06%2F07%2Fandroid-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11%2F&via=androidguys"><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a>
<a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://www.androidguys.com/2018/06/07/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
<a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://www.androidguys.com/2018/06/07/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11/&amp;media=http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080.png&description=Android+P+Beta+2%2C+Honor+Turbo+Charging%2C+and+Moto+Z3+Play+%28Episode+11%29" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
<a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Android+P+Beta+2%2C+Honor+Turbo+Charging%2C+and+Moto+Z3+Play+%28Episode+11%29%20-%20http%3A%2F%2Fwww.androidguys.com%2F2018%2F06%2F07%2Fandroid-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11%2F"><i class="td-icon-whatsapp"></i></a>
</div></div>
<div class="td-post-content">
<div class="td-post-featured-image"><a href="http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080.png" data-caption=""><img width="696" height="696" class="entry-thumb td-modal-image" src="http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080-696x696.png" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080-696x696.png 696w, http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080-130x130.png 130w, http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080-300x300.png 300w, http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080-768x768.png 768w, http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080-1024x1024.png 1024w, http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080-1068x1068.png 1068w, http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080-420x420.png 420w, http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080.png 1080w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="z3_1080" /></a></div>
<div class="td-a-rec td-a-rec-id-content_top  "><div class="vc_row wpb_row td-pb-row"><div class="wpb_column vc_column_container td-pb-span12"><div class="vc_column-inner "><div class="wpb_wrapper"><div class="vc_btn3-container vc_btn3-center">
<a class="vc_general vc_btn3 vc_btn3-size-md vc_btn3-shape-square vc_btn3-style-flat vc_btn3-icon-left vc_btn3-color-juicy-pink" href="http://www.androidguys.com/category/podcast/" title=""><i class="vc_btn3-icon fa fa-headphones"></i> Listen to the latest podcast!</a></div>
</div></div></div></div>
</div><p>Welcome to the latest episode of the AndroidGuys Audio Experience! For today we&#8217;ve tackled the new Android P Developer Preview update, how Honor is looking for an edge, the first smartwatch from fashion designer Marc Jacobs, and the Moto Z3 Play.</p>
<h3>Topics</h3>
<ul>
<li><a href="http://www.androidguys.com/2018/06/07/android-p-beta-2-pixel/" target="_blank" rel="noopener">Android P Developer Preview 3 released</a></li>
<li><a href="http://www.androidguys.com/2018/06/05/marc-jacobs-riley-touchscreen/" target="_blank" rel="noopener">Marc Jacobs releases its first smartwatch</a></li>
<li><a href="https://www.techradar.com/news/honor-will-roll-out-a-gpu-turbo-update-to-enhance-gaming-on-several-of-its-phones" target="_blank" rel="noopener">Some Honor phones will get an update to boost game performance</a></li>
<li><a href="http://www.androidguys.com/2018/06/06/moto-z3-play-official/" target="_blank" rel="noopener">The Moto Z3 Play goes official</a></li>
</ul>
<p>It’s our goal to keep these podcasts short but there&#8217;s a reason we lovingly refer to it as &#8220;The 15-minute podcast that&#8217;s never 15 minutes&#8221;. We hope you enjoy the show!</p>
<p><iframe src="https://embed.simplecast.com/7dfc034a?color=f5f5f5" width="100%" height="200px" frameborder="0" scrolling="no" seamless=""></iframe></p>
<h3>Other news to know</h3>
<ul>
<li>The <a title="" class="aalmanual" target="_self" href="http://https://www.verizonwireless.com/">Verizon</a> <a title="" class="aalmanual" target="_self" href="http://www.androidguys.com/samsung-galaxy-s7/">Samsung Galaxy S7</a> and <a title="" class="aalmanual" target="_self" href="http://www.androidguys.com/samsung-galaxy-s7-edge/">Galaxy S7 Edge</a> are <a href="http://pocketnow.com/2018/06/07/verizon-samsung-galaxy-s7-s7-edge-oreo-updates" target="_blank" rel="noopener">finally getting an update</a>. After several false starts, the fantastic phones from 2016 will finally be updated to Android Oreo. The update was previously pulled with no mention of when a fix might be issues. Now, we&#8217;re seeing support documents go up on Verizon&#8217;s website which indicates the software update is incoming. Unfortunately, users will be on an outdated April security patch, but at least it&#8217;s an update of some sort!</li>
<li>Essential owners can now get the latest Android P beta. Andy Rubin&#8217;s company is <a href="https://www.androidpolice.com/2018/06/06/android-p-beta-1-rolling-essential-phone/" target="_blank" rel="noopener">now rolling out</a> Android P Beta 1. The name is different, but it&#8217;s the exact same software experience the <a href="http://www.androidguys.com/2018/06/07/android-p-beta-2-pixel/" target="_blank" rel="noopener">Android Developer Preview Beta 2</a> that was released yesterday to Pixel owners. The update brings a new security patch, adaptive battery options, and more.</li>
<li>The special edition OnePlus 6 in Silk White <a href="https://www.androidpolice.com/2018/06/06/oneplus-6-limited-edition-silk-white-sells-day-new-drop-scheduled-june-12th/" target="_blank" rel="noopener">sold out in under a day</a>. The White with Gold time version of the device was put on sale yesterday and sold out quickly. But, fear not, it&#8217;ll be back soon. OnePlus announced a limited amount of the beautiful budget flagship will be available on June 12.</li>
<li>Looking for a new phone? We&#8217;ve just released our Best Flagship Phones list for June. <a href="http://www.androidguys.com/2018/06/06/best-android-smartphones-flagships-june-2018-2/" target="_blank" rel="noopener">Check it out here</a>!</li>
</ul>
<h3>Subscribe to the AndroidGuys Audio Experience!</h3>
<p>You can download or subscribe to the podcasts wherever you normally find your favorite shows. For your convenience, you can also click the links below.</p>
<p style="text-align: center;"><a href="https://play.google.com/music/listen?u=0#/ps/Igj5y5yt44tunjwcopcvkibi7ym" target="_blank" rel="noopener">Google Play Music</a> | <a href="https://rss.simplecast.com/podcasts/4377/rss" target="_blank" rel="noopener">Simplecast</a> | <a href="https://itunes.apple.com/us/podcast/the-androidguys-audio-experience/id1385162188" target="_blank" rel="noopener">iTunes</a> | <a href="http://stitcher.com/s?fid=186219&amp;refid=stpr" target="_blank" rel="noopener">Stitcher</a> | <a href="https://pca.st/bfpo" target="_blank" rel="noopener">Pocket Casts</a></p>
<p>For questions, concerns, or general feedback about the podcast feel free to contact us at podcast [at] androidguys.com.</p>
<div class="td-a-rec td-a-rec-id-content_bottom  "><script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=0acc898f-4b02-4b41-9e87-a65f7814fbbb" type="8659d7c75a0ee512be482942-"></script></div> </div>
<footer>
<div class="td-post-source-tags">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://www.androidguys.com/tag/android-p-developer-preview/">android p developer preview</a></li><li><a href="http://www.androidguys.com/tag/honor/">honor</a></li><li><a href="http://www.androidguys.com/tag/honor-10/">Honor 10</a></li><li><a href="http://www.androidguys.com/tag/honor-7x/">Honor 7X</a></li><li><a href="http://www.androidguys.com/tag/honor-9-lite/">Honor 9 Lite</a></li><li><a href="http://www.androidguys.com/tag/honor-view-10/">Honor View 10</a></li><li><a href="http://www.androidguys.com/tag/marc-jacobs/">Marc Jacobs</a></li><li><a href="http://www.androidguys.com/tag/marc-jacobs-riley-touchscreen/">Marc Jacobs Riley Touchscreen</a></li><li><a href="http://www.androidguys.com/tag/motorola/">motorola</a></li><li><a href="http://www.androidguys.com/tag/motorola-moto-z3-play/">Motorola Moto Z3 Play</a></li></ul> </div>
<div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://www.androidguys.com/2018/06/07/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://www.androidguys.com/2018/06/07/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11/" data-text="Android P Beta 2, Honor Turbo Charging, and Moto Z3 Play (Episode 11)" data-via="" data-lang="en">tweet</a> <script type="8659d7c75a0ee512be482942-">!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://www.androidguys.com/2018/06/07/google-congress-huawei-privacy/">Congress scrutinizes Google&#8217;s deal with Huawei over privacy concerns</a></div></div><div class="td-next-prev-separator"></div></div> <div class="author-box-wrap"><a href="http://www.androidguys.com/author/matt-adams/"><img alt='' src='http://0.gravatar.com/avatar/9f236e5a27be8432d630824ff3ec9717?s=96&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/9f236e5a27be8432d630824ff3ec9717?s=192&amp;d=mm&amp;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="http://www.androidguys.com/author/matt-adams/">Matt Adams</a></span></div><div class="td-author-description">Matt is an avid sports and technology fan and Managing Editor for AndroidGuys.com. You can get in touch with him by email at <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="9ef3ffeaeab0fffafff3eddefff0faecf1f7faf9ebe7edb0fdf1f3">[email&#160;protected]</a></div><div class="td-author-social">
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#125f7366663c5376737f6152537c76607d7b7655676b613c717d7f" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/madams1925" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class="clearfix"></div></div></div> <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Matt Adams"></span><meta itemprop="datePublished" content="2018-06-07T17:00:31+00:00"><meta itemprop="dateModified" content="2018-06-07T11:56:50+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://www.androidguys.com/2018/06/07/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11/" /><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.androidguys.com/wp-content/uploads/2017/03/ag_logo_270_90_android.png"></span><meta itemprop="name" content="AndroidGuys"></span><meta itemprop="headline " content="Android P Beta 2, Honor Turbo Charging, and Moto Z3 Play (Episode 11)"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.androidguys.com/wp-content/uploads/2018/06/z3_1080.png"><meta itemprop="width" content="1080"><meta itemprop="height" content="1080"></span> </footer>
</article> 

<script data-cfasync="false" src="/cdn-cgi/scripts/f2bf09f8/cloudflare-static/email-decode.min.js"></script><script type="8659d7c75a0ee512be482942-text/javascript">
	if (!window.OX_ads) { OX_ads = []; }
	OX_ads.push({ "auid" : "539238728" });
	</script>
<script type="8659d7c75a0ee512be482942-text/javascript">
	document.write('<scr'+'ipt src="//titangate-d.openx.net/w/1.0/jstag"><\/scr'+'ipt>');
	</script>
<noscript><iframe id="ff380f9077" name="ff380f9077" src="//titangate-d.openx.net/w/1.0/afr?auid=539238728&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="1" height="1"><a href="//titangate-d.openx.net/w/1.0/rc?cs=ff380f9077&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//titangate-d.openx.net/w/1.0/ai?auid=539238728&cs=ff380f9077&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
<div class="td_block_wrap td_block_related_posts td_uid_17_5b199cf526d48_rand td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_17_5b199cf526d48"><script type="8659d7c75a0ee512be482942-">var block_td_uid_17_5b199cf526d48 = new tdBlock();
block_td_uid_17_5b199cf526d48.id = "td_uid_17_5b199cf526d48";
block_td_uid_17_5b199cf526d48.atts = '{"limit":3,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_17_5b199cf526d48_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_17_5b199cf526d48_rand","live_filter":"cur_post_same_categories","live_filter_cur_post_id":139438,"live_filter_cur_post_author":"1479"}';
block_td_uid_17_5b199cf526d48.td_column_number = "3";
block_td_uid_17_5b199cf526d48.block_type = "td_block_related_posts";
block_td_uid_17_5b199cf526d48.post_count = "3";
block_td_uid_17_5b199cf526d48.found_posts = "10";
block_td_uid_17_5b199cf526d48.header_color = "";
block_td_uid_17_5b199cf526d48.ajax_pagination_infinite_stop = "";
block_td_uid_17_5b199cf526d48.max_num_pages = "4";
tdBlocksArray.push(block_td_uid_17_5b199cf526d48);
</script><h4 class="td-related-title"><a id="td_uid_18_5b199cf527d9b" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_17_5b199cf526d48" href="#">RELATED ARTICLES</a><a id="td_uid_19_5b199cf527dfc" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_17_5b199cf526d48" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_17_5b199cf526d48 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/07/blackberry-key-2/" rel="bookmark" title="Hot Take: BlackBerry Key2 (Episode 12)"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/key2trio-218x150.png" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/key2trio-218x150.png 218w, http://www.androidguys.com/wp-content/uploads/2018/06/key2trio-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Hot Take: BlackBerry Key2 (Episode 12)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/07/blackberry-key-2/" rel="bookmark" title="Hot Take: BlackBerry Key2 (Episode 12)">Hot Take: BlackBerry Key2 (Episode 12)</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/05/android-patches-google-lens-gaming-phones/" rel="bookmark" title="Android Patches, Google Lens, and Gaming Phones (Episode 10)"><img width="218" height="150" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/ASUS-ROG-Phone-Extra-3-218x150.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/ASUS-ROG-Phone-Extra-3-218x150.jpg 218w, http://www.androidguys.com/wp-content/uploads/2018/06/ASUS-ROG-Phone-Extra-3-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Android Patches, Google Lens, and Gaming Phones (Episode 10)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/05/android-patches-google-lens-gaming-phones/" rel="bookmark" title="Android Patches, Google Lens, and Gaming Phones (Episode 10)">Android Patches, Google Lens, and Gaming Phones (Episode 10)</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/05/30/hot-take-lg-v35-thinq/" rel="bookmark" title="Hot Take: LG V35 ThinQ (Episode 8)"><img width="1" height="1" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/05/lv_v35_thinq-wide.jpg" alt="" title="Hot Take: LG V35 ThinQ (Episode 8)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/05/30/hot-take-lg-v35-thinq/" rel="bookmark" title="Hot Take: LG V35 ThinQ (Episode 8)">Hot Take: LG V35 ThinQ (Episode 8)</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_17_5b199cf526d48" data-td_block_id="td_uid_17_5b199cf526d48"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_17_5b199cf526d48" data-td_block_id="td_uid_17_5b199cf526d48"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
<div id="disqus_thread"></div>
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<div class="td-a-rec td-a-rec-id-custom_ad_2  "><div class="td-visible-desktop">
<div id='div-gpt-ad-1487239195458-0' style='height:600px; width:300px;'>
<script type="8659d7c75a0ee512be482942-">googletag.cmd.push(function() { googletag.display('div-gpt-ad-1487239195458-0'); });
</script>
</div>
</div>
<div class="td-visible-phone">
<div id='div-gpt-ad-1499250035802-0' style='height:250px; width:300px;'>
<script type="8659d7c75a0ee512be482942-">googletag.cmd.push(function() { googletag.display('div-gpt-ad-1499250035802-0'); });
</script>
</div>
</div></div><div class="td_block_wrap td_block_2 td_block_widget td_uid_21_5b199cf52aa27_rand td-pb-border-top" data-td-block-uid="td_uid_21_5b199cf52aa27">
<style scoped>
.td_uid_21_5b199cf52aa27_rand .td_module_wrap:hover .entry-title a,
            .td_uid_21_5b199cf52aa27_rand a.td-pulldown-filter-link:hover,
            .td_uid_21_5b199cf52aa27_rand .td-subcat-item a:hover,
            .td_uid_21_5b199cf52aa27_rand .td-subcat-item .td-cur-simple-item,
            .td_uid_21_5b199cf52aa27_rand .td_quote_on_blocks,
            .td_uid_21_5b199cf52aa27_rand .td-opacity-cat .td-post-category:hover,
            .td_uid_21_5b199cf52aa27_rand .td-opacity-read .td-read-more a:hover,
            .td_uid_21_5b199cf52aa27_rand .td-opacity-author .td-post-author-name a:hover,
            .td_uid_21_5b199cf52aa27_rand .td-instagram-user a {
                color: #fb8c00;
            }

            .td_uid_21_5b199cf52aa27_rand .td-next-prev-wrap a:hover,
            .td_uid_21_5b199cf52aa27_rand .td-load-more-wrap a:hover {
                background-color: #fb8c00;
                border-color: #fb8c00;
            }

            .td_uid_21_5b199cf52aa27_rand .block-title span,
            .td_uid_21_5b199cf52aa27_rand .td-trending-now-title,
            .td_uid_21_5b199cf52aa27_rand .block-title a,
            .td_uid_21_5b199cf52aa27_rand .td-read-more a,
            .td_uid_21_5b199cf52aa27_rand .td-weather-information:before,
            .td_uid_21_5b199cf52aa27_rand .td-weather-week:before,
            .td_uid_21_5b199cf52aa27_rand .td-subcat-dropdown:hover .td-subcat-more,
            .td_uid_21_5b199cf52aa27_rand .td-exchange-header:before,
            .td_uid_21_5b199cf52aa27_rand .td-post-category:hover {
                background-color: #fb8c00;
            }

            .td_uid_21_5b199cf52aa27_rand .block-title {
                border-color: #fb8c00;
            }

            
            .td_uid_21_5b199cf52aa27_rand .block-title span,
            .td_uid_21_5b199cf52aa27_rand .td-trending-now-title,
            .td_uid_21_5b199cf52aa27_rand .block-title a {
                color: #ffffff;
            }
</style><script type="8659d7c75a0ee512be482942-">var block_td_uid_21_5b199cf52aa27 = new tdBlock();
block_td_uid_21_5b199cf52aa27.id = "td_uid_21_5b199cf52aa27";
block_td_uid_21_5b199cf52aa27.atts = '{"limit":"1","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"27584","category_ids":"","custom_title":"Featured","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#fb8c00","header_text_color":"#ffffff","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_21_5b199cf52aa27_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_21_5b199cf52aa27_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5b199cf52aa27.td_column_number = "1";
block_td_uid_21_5b199cf52aa27.block_type = "td_block_2";
block_td_uid_21_5b199cf52aa27.post_count = "1";
block_td_uid_21_5b199cf52aa27.found_posts = "2918";
block_td_uid_21_5b199cf52aa27.header_color = "#fb8c00";
block_td_uid_21_5b199cf52aa27.ajax_pagination_infinite_stop = "";
block_td_uid_21_5b199cf52aa27.max_num_pages = "2918";
tdBlocksArray.push(block_td_uid_21_5b199cf52aa27);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span>Featured</span></h4></div><div id=td_uid_21_5b199cf52aa27 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_2 td_module_wrap td-animation-stack">
 <div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/06/huawei-watch-2-classic-giveaway/" rel="bookmark" title="HUAWEI Watch 2 Classic Giveaway"><img width="324" height="160" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/HUAWEI-Watch-2-Classic-5-324x160.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/HUAWEI-Watch-2-Classic-5-324x160.jpg 324w, http://www.androidguys.com/wp-content/uploads/2018/06/HUAWEI-Watch-2-Classic-5-533x261.jpg 533w" sizes="(max-width: 324px) 100vw, 324px" alt="" title="HUAWEI Watch 2 Classic Giveaway" /></a></div> </div>
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/06/huawei-watch-2-classic-giveaway/" rel="bookmark" title="HUAWEI Watch 2 Classic Giveaway">HUAWEI Watch 2 Classic Giveaway</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-06-06T17:00:00+00:00">June 6, 2018</time></span> </div>
<div class="td-excerpt">
It's time for another giveaway! We're teaming up with HUAWEI and YOU can win. Enter here to win a beautiful new HUAWEI Watch 2 Classic! </div>
</div>
</div> </div></div> <div class="td-a-rec td-a-rec-id-custom_ad_3  ">
<div class="td-all-devices">

<div id='div-gpt-ad-1487237564018-0' style='height:250px; width:300px;'>
<script type="8659d7c75a0ee512be482942-">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1487237564018-0'); });
</script>
</div>
</div></div><div class="td_block_wrap td_block_2 td_block_widget td_uid_23_5b199cf52eb66_rand td-pb-border-top" data-td-block-uid="td_uid_23_5b199cf52eb66"><script type="8659d7c75a0ee512be482942-">var block_td_uid_23_5b199cf52eb66 = new tdBlock();
block_td_uid_23_5b199cf52eb66.id = "td_uid_23_5b199cf52eb66";
block_td_uid_23_5b199cf52eb66.atts = '{"limit":"3","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"5","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_23_5b199cf52eb66_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_23_5b199cf52eb66_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5b199cf52eb66.td_column_number = "1";
block_td_uid_23_5b199cf52eb66.block_type = "td_block_2";
block_td_uid_23_5b199cf52eb66.post_count = "3";
block_td_uid_23_5b199cf52eb66.found_posts = "19082";
block_td_uid_23_5b199cf52eb66.header_color = "#";
block_td_uid_23_5b199cf52eb66.ajax_pagination_infinite_stop = "";
block_td_uid_23_5b199cf52eb66.max_num_pages = "6361";
tdBlocksArray.push(block_td_uid_23_5b199cf52eb66);
</script><div class="td-block-title-wrap"></div><div id=td_uid_23_5b199cf52eb66 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_2 td_module_wrap td-animation-stack">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/07/google-congress-huawei-privacy/" rel="bookmark" title="Congress scrutinizes Google&#8217;s deal with Huawei over privacy concerns"><img width="324" height="160" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2017/08/Google-Headquarters-324x160.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2017/08/Google-Headquarters-324x160.jpg 324w, http://www.androidguys.com/wp-content/uploads/2017/08/Google-Headquarters-533x261.jpg 533w" sizes="(max-width: 324px) 100vw, 324px" alt="" title="Congress scrutinizes Google&#8217;s deal with Huawei over privacy concerns" /></a></div> </div>
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/07/google-congress-huawei-privacy/" rel="bookmark" title="Congress scrutinizes Google&#8217;s deal with Huawei over privacy concerns">Congress scrutinizes Google&#8217;s deal with Huawei over privacy concerns</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-06-07T14:09:10+00:00">June 7, 2018</time></span> </div>
<div class="td-excerpt">
Google is seeing scrutiny from the US Government thanks to its various partnerships with the likes of Huawei, Xiaomi, and TenCent. </div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/07/amazon-fire-tv-cube-launched/" rel="bookmark" title="Meet Amazon’s latest Alexa-powered device, the Fire TV Cube"><img width="100" height="70" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/Amazon-Fire-TV-Cube-3-100x70.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/Amazon-Fire-TV-Cube-3-100x70.jpg 100w, http://www.androidguys.com/wp-content/uploads/2018/06/Amazon-Fire-TV-Cube-3-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Meet Amazon’s latest Alexa-powered device, the Fire TV Cube" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/07/amazon-fire-tv-cube-launched/" rel="bookmark" title="Meet Amazon’s latest Alexa-powered device, the Fire TV Cube">Meet Amazon’s latest Alexa-powered device, the Fire TV Cube</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-06-07T11:00:03+00:00">June 7, 2018</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.androidguys.com/2018/06/07/blackberry-key2-official/" rel="bookmark" title="BlackBerry KEY2 is official with refined design, dual-camera setup"><img width="100" height="70" class="entry-thumb" src="http://www.androidguys.com/wp-content/uploads/2018/06/Main-100x70.jpg" srcset="http://www.androidguys.com/wp-content/uploads/2018/06/Main-100x70.jpg 100w, http://www.androidguys.com/wp-content/uploads/2018/06/Main-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="BlackBerry KEY2 is official with refined design, dual-camera setup" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/07/blackberry-key2-official/" rel="bookmark" title="BlackBerry KEY2 is official with refined design, dual-camera setup">BlackBerry KEY2 is official with refined design, dual-camera setup</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-06-07T10:15:48+00:00">June 7, 2018</time></span> </div>
</div>
</div>
</div> </div></div> <div class="td_block_wrap td_block_9 td_block_widget td_uid_24_5b199cf5335c3_rand td-pb-border-top" data-td-block-uid="td_uid_24_5b199cf5335c3">
<style scoped>
.td_uid_24_5b199cf5335c3_rand .td_module_wrap:hover .entry-title a,
            .td_uid_24_5b199cf5335c3_rand a.td-pulldown-filter-link:hover,
            .td_uid_24_5b199cf5335c3_rand .td-subcat-item a:hover,
            .td_uid_24_5b199cf5335c3_rand .td-subcat-item .td-cur-simple-item,
            .td_uid_24_5b199cf5335c3_rand .td_quote_on_blocks,
            .td_uid_24_5b199cf5335c3_rand .td-opacity-cat .td-post-category:hover,
            .td_uid_24_5b199cf5335c3_rand .td-opacity-read .td-read-more a:hover,
            .td_uid_24_5b199cf5335c3_rand .td-opacity-author .td-post-author-name a:hover,
            .td_uid_24_5b199cf5335c3_rand .td-instagram-user a {
                color: #fb8c00;
            }

            .td_uid_24_5b199cf5335c3_rand .td-next-prev-wrap a:hover,
            .td_uid_24_5b199cf5335c3_rand .td-load-more-wrap a:hover {
                background-color: #fb8c00;
                border-color: #fb8c00;
            }

            .td_uid_24_5b199cf5335c3_rand .block-title span,
            .td_uid_24_5b199cf5335c3_rand .td-trending-now-title,
            .td_uid_24_5b199cf5335c3_rand .block-title a,
            .td_uid_24_5b199cf5335c3_rand .td-read-more a,
            .td_uid_24_5b199cf5335c3_rand .td-weather-information:before,
            .td_uid_24_5b199cf5335c3_rand .td-weather-week:before,
            .td_uid_24_5b199cf5335c3_rand .td-subcat-dropdown:hover .td-subcat-more,
            .td_uid_24_5b199cf5335c3_rand .td-exchange-header:before,
            .td_uid_24_5b199cf5335c3_rand .td-post-category:hover {
                background-color: #fb8c00;
            }

            .td_uid_24_5b199cf5335c3_rand .block-title {
                border-color: #fb8c00;
            }

            
            .td_uid_24_5b199cf5335c3_rand .block-title span,
            .td_uid_24_5b199cf5335c3_rand .td-trending-now-title,
            .td_uid_24_5b199cf5335c3_rand .block-title a {
                color: #ffffff;
            }
</style><script type="8659d7c75a0ee512be482942-">var block_td_uid_24_5b199cf5335c3 = new tdBlock();
block_td_uid_24_5b199cf5335c3.id = "td_uid_24_5b199cf5335c3";
block_td_uid_24_5b199cf5335c3.atts = '{"limit":"1","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"19360","category_ids":"","custom_title":"Learn Something New!","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#fb8c00","header_text_color":"#ffffff","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_24_5b199cf5335c3_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_24_5b199cf5335c3_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_24_5b199cf5335c3.td_column_number = "1";
block_td_uid_24_5b199cf5335c3.block_type = "td_block_9";
block_td_uid_24_5b199cf5335c3.post_count = "1";
block_td_uid_24_5b199cf5335c3.found_posts = "463";
block_td_uid_24_5b199cf5335c3.header_color = "#fb8c00";
block_td_uid_24_5b199cf5335c3.ajax_pagination_infinite_stop = "";
block_td_uid_24_5b199cf5335c3.max_num_pages = "463";
tdBlocksArray.push(block_td_uid_24_5b199cf5335c3);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span>Learn Something New!</span></h4></div><div id=td_uid_24_5b199cf5335c3 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_8 td_module_wrap">
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.androidguys.com/2018/06/06/improve-call-quality-android-phone/" rel="bookmark" title="How to improve call quality on your Android phone">How to improve call quality on your Android phone</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-06-06T20:00:09+00:00">June 6, 2018</time></span> </div>
</div>
</div>
</div> </div></div> <div class="td-a-rec td-a-rec-id-custom_ad_4  ">
<div class="td-all-devices">

<div id='div-gpt-ad-1487237631062-0' style='height:250px; width:300px;'>
<script type="8659d7c75a0ee512be482942-">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1487237631062-0'); });
</script>
</div>
</div></div> </div>
</div>

<script type="8659d7c75a0ee512be482942-text/javascript">
			if (!window.OX_ads) { OX_ads = []; }
				OX_ads.push({ "auid" : "539506612" });
			</script>
<script type="8659d7c75a0ee512be482942-text/javascript">
			document.write('<scr'+'ipt src="//titangate-d.openx.net/w/1.0/jstag"><\/scr'+'ipt>');
			</script>
<noscript><iframe id="177a1ce0e8" name="177a1ce0e8" src="//titangate-d.openx.net/w/1.0/afr?auid=539506612&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="1" height="1"><a href="//titangate-d.openx.net/w/1.0/rc?cs=177a1ce0e8&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//titangate-d.openx.net/w/1.0/ai?auid=539506612&cs=177a1ce0e8&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
</div> 
</div> 
</div> 


<div class="td-footer-wrapper">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span12">
<aside class="widget_text widget widget_custom_html"><div class="block-title"><span>Listen Now!</span></div><div class="textwidget custom-html-widget"><iframe frameborder='0' height='200px' scrolling='no' seamless src='https://embed.simplecast.com/fb73f7e6?color=f5f5f5' width='100%'></iframe></div></aside> </div>
</div>
</div>
<div class="td-footer-bottom-full">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="http://www.androidguys.com/"><img class="td-retina-data" src="http://www.androidguys.com/wp-content/uploads/2017/03/ag_logo_270_90_android.png" data-retina="http://www.androidguys.com/wp-content/uploads/2017/03/ag_logo_544_180.png" alt="AndroidGuys" title="" /></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Now in our 11th year, AndroidGuys loves to provide readers with the latest news and rumors as well as reviews, opinion pieces, and tools to get more from your Android. You have an awesome phone in your pocket; let us help you get more from it.<div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#f68684938585b697989284999f9291838f85d895999b"><span class="__cf_email__" data-cfemail="d2a2a0b7a1a192b3bcb6a0bdbbb6b5a7aba1fcb1bdbf">[email&#160;protected]</span></a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.facebook.com/androidguys" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.instagram.com/androidguys" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.androidguys.com/feed/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.twitter.com/androidguys" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></aside></div> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span7 td-sub-footer-menu">
</div>
<div class="td-pb-span5 td-sub-footer-copy">
&copy; </div>
</div>
</div>
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/f2bf09f8/cloudflare-static/email-decode.min.js"></script><script src="https://apis.google.com/js/plusone.js" type="8659d7c75a0ee512be482942-"></script>

<script type="8659d7c75a0ee512be482942-"> 
    var amzn_ps_tracking_id = "andro0eb-20"; 
    var amzn_ps_instance_id = "3b2080bb-084f-4f79-9eca-229a944a5a5f";
  </script>
<script async="true" type="8659d7c75a0ee512be482942-text/javascript" src="//ps-us.amazon-adsystem.com/scripts/US/studio.js" charset="UTF-8"></script>
<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=f8a9d144-449a-4897-8c59-9d53e8826517" type="8659d7c75a0ee512be482942-"></script>
<script type="8659d7c75a0ee512be482942-application/javascript" src="http://www9.smartadserver.com/ac?out=js&nwid=1331&siteid=94704&pgname=.2_11159.3_androidguys.com_tier1_/hi/&fmtid=44627&tgt=[sas_target]&visit=m&tmstp=[timestamp]&clcturl=[countgo]"></script>
<script type="8659d7c75a0ee512be482942-application/javascript" src="http://www9.smartadserver.com/ac?out=js&nwid=1331&siteid=94704&pgname=.2_11160.5_androidguys.com_tier1_/hi/&fmtid=44627&tgt=[sas_target]&visit=m&tmstp=[timestamp]&clcturl=[countgo]"></script>
<script type="8659d7c75a0ee512be482942-application/javascript" src="http://www9.smartadserver.com/ac?out=js&nwid=1331&siteid=94704&pgname=.2_12083.46_androidguys.com_tier1_/hi/&fmtid=44627&tgt=[sas_target]&visit=m&tmstp=[timestamp]&clcturl=[countgo]"></script>
<script type="8659d7c75a0ee512be482942-">
(function() {
	var scr = document.createElement('SCRIPT');

	var affRandom = Math.random();

	if(affRandom < 0.5) {
		scr.src = '//s.skimresources.com/js/75515X1525641.skimlinks.js';
	} else {
		scr.innerHTML = "var vglnk = { key: 'e4cba27956e5c5ec98ac9e9f2246ea5b' };"
		scr.innerHTML += "(function(d, t) {";
		scr.innerHTML += "var s = d.createElement(t);";
		scr.innerHTML += "s.type = 'text/javascript';";
		scr.innerHTML += "s.async = true;";
		scr.innerHTML += "s.src = '//cdn.viglink.com/api/vglnk.js';";
		scr.innerHTML += "var r = d.getElementsByTagName(t)[0];";
		scr.innerHTML += "r.parentNode.insertBefore(s, r);";
		scr.innerHTML += "}(document, 'script'));";
	}

	document.body.appendChild(scr);
}) ();
</script>
<script data-cfasync="false" type="text/javascript">
(function() {var s=document.createElement('script'); s.type='text/javascript'; s.async=true; s.src='//nextmillennium.liqwid.net/?key=D85D-A6F1-B041-B88A'; var x=document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s,x);})();
</script> 


<style type="text/css" media="screen">

/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 768px) and (max-width: 1018px) {
.td-pb-span8 {
    width: 440px;
}
.td-pb-span4 {
    width: 328px;
}
}
</style>
<script type="8659d7c75a0ee512be482942-text/javascript">function getBrowserSize(){
       var w, h;

         if(typeof window.innerWidth != 'undefined')
         {
          w = window.innerWidth; //other browsers
          h = window.innerHeight;
         } 
         else if(typeof document.documentElement != 'undefined' && typeof document.documentElement.clientWidth != 'undefined' && document.documentElement.clientWidth !== 0) 
         {
          w =  document.documentElement.clientWidth; //IE
          h = document.documentElement.clientHeight;
         }
         else{
          w = document.body.clientWidth; //IE
          h = document.body.clientHeight;
         }
       return {'width':w, 'height': h};
}

if(parseInt(getBrowserSize().width) <= 768){
	var spots = document.getElementsByClassName("td-visible-desktop");
	for (let i = 0; i<spots.length; i++){
		spots[i].remove();
	}
}
else {
	var spots = document.getElementsByClassName("td-visible-phone");
	for (let i = 0; i<spots.length; i++){
		spots[i].remove();
	}
}</script><link rel='stylesheet' id='aal_style-css' href='http://www.androidguys.com/wp-content/plugins/wp-auto-affiliate-links/css/style.css?ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='http://www.androidguys.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?ver=5.4.2' type='text/css' media='all' />
<script type="8659d7c75a0ee512be482942-text/javascript">
/* <![CDATA[ */
var countVars = {"disqusShortname":"androidguys"};
/* ]]> */
</script>
<script type="8659d7c75a0ee512be482942-text/javascript" src='http://www.androidguys.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type="8659d7c75a0ee512be482942-text/javascript">
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"139438 http:\/\/www.androidguys.com\/?p=139438","disqusShortname":"androidguys","disqusTitle":"Android P Beta 2, Honor Turbo Charging, and Moto Z3 Play (Episode 11)","disqusUrl":"http:\/\/www.androidguys.com\/2018\/06\/07\/android-p-developer-preview-marc-jacobs-honor-moto-z3-play-episode-11\/","postId":"139438"};
/* ]]> */
</script>
<script type="8659d7c75a0ee512be482942-text/javascript" src='http://www.androidguys.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type="8659d7c75a0ee512be482942-text/javascript" src='http://www.androidguys.com/wp-content/plugins/wp-auto-affiliate-links/js/api.js?ver=4.8.6'></script>
<script type="8659d7c75a0ee512be482942-text/javascript" src='http://www.androidguys.com/wp-content/themes/Newspaper2/js/tagdiv_theme.js?ver=7.6.1'></script>
<script type="8659d7c75a0ee512be482942-text/javascript" src='http://www.androidguys.com/wp-includes/js/comment-reply.min.js?ver=4.8.6'></script>
<script type="8659d7c75a0ee512be482942-text/javascript" src='http://www.androidguys.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=2.9.8'></script>
<script type="8659d7c75a0ee512be482942-text/javascript">
/* <![CDATA[ */
var ajax_script = {"ajaxurl":"http:\/\/www.androidguys.com\/wp-admin\/admin-ajax.php","aal_plugin_url":"http:\/\/www.androidguys.com\/wp-content\/plugins\/wp-auto-affiliate-links\/"};
/* ]]> */
</script>
<script type="8659d7c75a0ee512be482942-text/javascript" src='http://www.androidguys.com/wp-content/plugins/wp-auto-affiliate-links/js/js.js?ver=4.8.6'></script>
<script type="8659d7c75a0ee512be482942-text/javascript" src='http://www.androidguys.com/wp-includes/js/wp-embed.min.js?ver=4.8.6'></script>
<script type="8659d7c75a0ee512be482942-text/javascript" src='http://www.androidguys.com/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js?ver=5.4.2'></script>

<script type="8659d7c75a0ee512be482942-">
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://www.androidguys.com/wp-content/themes/Newspaper2/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://www.androidguys.com/wp-content/themes/Newspaper2';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
<script src="https://ajax.cloudflare.com/cdn-cgi/scripts/4f936b58/cloudflare-static/rocket-loader.min.js" data-cf-nonce="8659d7c75a0ee512be482942-" defer=""></script></body>
</html>
