<!doctype html >
<!--[if IE 8]><html
class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]><html
class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--><html lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]--><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://www.androidguys.com/xmlrpc.php" /><meta property="og:image" content="https://www.androidguys.com/wp-content/uploads/2017/03/raspberry-pi-image.jpg" /><meta name="author" content="AndroidGuys"><link rel="icon" type="image/png" href="https://www.androidguys.com/wp-content/uploads/2018/04/ag-favicon-2018.png"><title>The Ultimate Raspberry Pi eBook bundle is yours for $20 today</title><meta name="description" content="The possibilities with a Raspberry Pi is almost limitless. Learn everything you need to use this popular platform at its fullest for pennies on the dollar." /><link rel="canonical" href="https://www.androidguys.com/deals/ultimate-raspberry-pi-ebook-bundle/" /> <script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/www.androidguys.com\/","sameAs":["http:\/\/www.facebook.com\/androidguys","http:\/\/www.instagram.com\/androidguys","https:\/\/twitter.com\/androidguys"],"@id":"https:\/\/www.androidguys.com\/#organization","name":"AndroidGuys","logo":""}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="AndroidGuys &raquo; Feed" href="https://www.androidguys.com/feed/" /><link rel="alternate" type="application/rss+xml" title="AndroidGuys &raquo; Comments Feed" href="https://www.androidguys.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="AndroidGuys &raquo; The Ultimate Raspberry Pi eBook bundle is yours for $20 today Comments Feed" href="https://www.androidguys.com/deals/ultimate-raspberry-pi-ebook-bundle/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.androidguys.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,img.emoji {
display:inline !important;
border:none !important;
box-shadow:none !important;
height:1em !important;
width:1em !important;
margin:0 .07em!important;
vertical-align:-.1em !important;
background:none !important;
padding:0!important;
}</style><link rel='stylesheet' id='google_font_open_sans-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.8' type='text/css' media='all' /><link rel='stylesheet' id='google_font_roboto-css' href='https://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.8' type='text/css' media='all' /><link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C700&#038;ver=4.9.8' type='text/css' media='all' /><link rel='stylesheet' id='js_composer_front-css' href='https://www.androidguys.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.5.4' type='text/css' media='all' /><link rel='stylesheet' id='td-theme-css' href='https://www.androidguys.com/wp-content/themes/Newspaper2/style.css?ver=7.6.1' type='text/css' media='all' /> <script type='text/javascript' src='https://www.androidguys.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript' src='https://www.androidguys.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <link rel='https://api.w.org/' href='https://www.androidguys.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.androidguys.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.androidguys.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.9.8" /><link rel='shortlink' href='https://www.androidguys.com/?p=147994' /><link rel="alternate" type="application/json+oembed" href="https://www.androidguys.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidguys.com%2Fdeals%2Fultimate-raspberry-pi-ebook-bundle%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.androidguys.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidguys.com%2Fdeals%2Fultimate-raspberry-pi-ebook-bundle%2F&#038;format=xml" />
<!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]--><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<!--[if lte IE 9]><link
rel="stylesheet" type="text/css" href="https://www.androidguys.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><link rel="amphtml" href="https://www.androidguys.com/deals/ultimate-raspberry-pi-ebook-bundle/amp/">
<script>/*<![CDATA[*/var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=false;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop='';}
(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10';}
if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11';}
if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios';}
var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android';}
if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x';}
if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome';}
if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox';}
if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari';}
if(-1!==navigator.userAgent.indexOf('IEMobile')){htmlTag.className+=' td-md-is-iemobile';}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id];},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;},get:function(resource_id){return tdLocalCache.data[resource_id];},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData;}};})();var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var tds_general_modal_image="yes";var td_ajax_url="https:\/\/www.androidguys.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.6.1";var td_get_template_directory_uri="https:\/\/www.androidguys.com\/wp-content\/themes\/Newspaper2";var tds_snap_menu="snap";var tds_logo_on_sticky="";var tds_header_style="3";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="";var tds_more_articles_on_post_time_to_wait="1";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#48c2f9";var tds_smart_sidebar="enabled";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var td_ad_background_click_link="";var td_ad_background_click_target="";/*]]>*/</script> <style>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</style> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga');ga('create','UA-2973238-3','auto');ga('send','pageview');</script><link rel="icon" href="https://www.androidguys.com/wp-content/uploads/2018/06/cropped-AG-Logo-Standalone_sq-white-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.androidguys.com/wp-content/uploads/2018/06/cropped-AG-Logo-Standalone_sq-white-192x192.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://www.androidguys.com/wp-content/uploads/2018/06/cropped-AG-Logo-Standalone_sq-white-180x180.png" /><meta name="msapplication-TileImage" content="https://www.androidguys.com/wp-content/uploads/2018/06/cropped-AG-Logo-Standalone_sq-white-270x270.png" />
<noscript><style type="text/css">.wpb_animate_when_almost_visible {
opacity:1;
}</style></noscript><meta property="og:locale" content="en_US" /><meta property="og:site_name" content="AndroidGuys" /><meta property="og:title" content="The Ultimate Raspberry Pi eBook bundle is yours for $20 today" /><meta property="og:url" content="https://www.androidguys.com/deals/ultimate-raspberry-pi-ebook-bundle/" /><meta property="og:type" content="article" /><meta property="og:description" content="The possibilities with a Raspberry Pi is almost limitless. Learn everything you need to use this popular platform at its fullest for pennies on the dollar." /><meta property="og:image" content="https://www.androidguys.com/wp-content/uploads/2017/03/raspberry-pi-image.jpg" /><meta property="article:published_time" content="2018-11-13T15:00:21+00:00" /><meta property="article:modified_time" content="2018-11-13T14:56:26+00:00" /><meta property="og:updated_time" content="2018-11-13T14:56:26+00:00" /><meta property="article:section" content="Deal of the Day" /><meta property="article:author" content="http://www.facebook.com/androidguys" /><meta itemprop="name" content="The Ultimate Raspberry Pi eBook bundle is yours for $20 today" /><meta itemprop="headline" content="The Ultimate Raspberry Pi eBook bundle is yours for $20 today" /><meta itemprop="description" content="The possibilities with a Raspberry Pi is almost limitless. Learn everything you need to use this popular platform at its fullest for pennies on the dollar." /><meta itemprop="image" content="https://www.androidguys.com/wp-content/uploads/2017/03/raspberry-pi-image.jpg" /><meta itemprop="datePublished" content="2018-11-13" /><meta itemprop="dateModified" content="2018-11-13T14:56:26+00:00" /><meta itemprop="author" content="AndroidGuys" /><meta name="twitter:title" content="The Ultimate Raspberry Pi eBook bundle is yours for $20 today" /><meta name="twitter:url" content="https://www.androidguys.com/deals/ultimate-raspberry-pi-ebook-bundle/" /><meta name="twitter:description" content="The possibilities with a Raspberry Pi is almost limitless. Learn everything you need to use this popular platform at its fullest for pennies on the dollar." /><meta name="twitter:image" content="https://www.androidguys.com/wp-content/uploads/2017/03/raspberry-pi-image.jpg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@androidguys" /><meta name="twitter:site" content="@androidguys" />
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga');ga('create','UA-2973238-3','auto');ga('send','pageview');</script> <script src="https://static.swappa.com/static/widget/widget.min.js" data-affiliate-code="scottwebster" async></script> <script type="text/javascript" src="https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js" async="true"></script> <script type="text/javascript" async=true>/*<![CDATA[*/var elem=document.createElement("script");elem.src="https://quantcast.mgr.consensu.org/cmp.js";elem.async=!0;elem.type="text/javascript";var scpt=document.getElementsByTagName("script")[0];scpt.parentNode.insertBefore(elem,scpt);(function(){function d(){if(!window.frames.__cmpLocator)if(document.body){var b=document.body,a=document.createElement("iframe");a.style="display:none";a.name="__cmpLocator";b.appendChild(a)}else setTimeout(d,5)}function c(b){var a="string"===typeof b.data;var c=a?-1!=b.data.indexOf("__cmpCall")?JSON.parse(b.data):{}:b.data;if(c.__cmpCall){var e=c.__cmpCall;window.__cmp(e.command,e.parameter,function(c,d){var f={__cmpReturn:{returnValue:c,success:d,callId:e.callId}};b.source.postMessage(a?JSON.stringify(f):f,"*")})}}d();window.__cmp=function(b){var a=arguments;if(a.length)if("ping"===a[0])a[2]({gdprAppliesGlobally:!1,cmpLoaded:!1},!0);else{if("__cmp"==b)return!1;"undefined"===typeof __cmp.a&&(__cmp.a=[]);__cmp.a.push([].slice.apply(a))}else return __cmp.a};window.__cmp.gdprAppliesGlobally=!1;window.__cmp.msgHandler=c;window.addEventListener?window.addEventListener("message",c,!1):window.attachEvent("onmessage",c)})();window.__cmp("init",{Language:"en","Initial Screen Reject Button Text":"I do not accept","Initial Screen Accept Button Text":"I accept","Purpose Screen Header Title Text":"Privacy settings","Purpose Screen Body Text":"You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.","Vendor Screen Body Text":"You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.","Vendor Screen Accept All Button Text":"Accept all","Vendor Screen Reject All Button Text":"Reject all","Initial Screen Body Text":"We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.","Initial Screen Body Text Option":1,"Publisher Name":"AndroidGuys","Publisher Logo":"http://www.androidguys.com/wp-content/uploads/2018/07/ag_logo_270-41.png","Min Days Between UI Displays":5,"Consent Scope":"service","No Option":!1,"Default Value for Toggles":"on"});/*]]>*/</script><style>.qc-cmp-publisher-logo {
padding-top:10px !important;
}

.qc-cmp-ui-content {
padding-top:10px !important;
padding-bottom:30px !important;
}

.qc-cmp-alt-buttons {
padding-bottom:30px !important;
}

.qc-cmp-title {
font-size:30px !important;
}

.qc-cmp-link-text,.qc-cmp-qc-link {
display:none !important;
}</style> <script type="application/ld+json">{"@context":"http://schema.org","@type":"Organization","name":"AndroidGuys","url":"http://www.androidguys.com","sameAs":["http://www.facebook.com/androidguys","http://instagram.com/androidguys","http://twitter.com/androidguys"]}</script> <script type="text/javascript" src="//dsh7ky7308k4b.cloudfront.net/publishers/androidguyscom.min.js?v2"></script> <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script> <script>var googletag=googletag||{};googletag.cmd=googletag.cmd||[];</script> <script>googletag.cmd.push(function(){googletag.defineSlot('/8095840/.2_8314.4_androidguys.com_tier1',[300,250],'div-gpt-ad-1487237631062-0').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_8317.5_androidguys.com_tier1',[320,50],'div-gpt-ad-1487238631958-0').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_8318.7_androidguys.com_tier1',[300,600],'div-gpt-ad-1487256038713-0').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_8319.4_androidguys.com_tier1',[300,250],'div-gpt-ad-1487238658175-0').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_8320.4_androidguys.com_tier1',[300,250],'div-gpt-ad-1487238677738-0').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_11211.4_androidguys.com_tier1',[300,250],'div-gpt-ad-1499250035802-0').addService(googletag.pubads());var slot8309=googletag.defineSlot('/8095840/.2_8309.3_androidguys.com_tier1',[728,90],'div-gpt-ad-1487237318659-0').addService(googletag.pubads());var slot8312=googletag.defineSlot('/8095840/.2_8312.7_androidguys.com_tier1',[300,600],'div-gpt-ad-1487239195458-0').addService(googletag.pubads());var slot8313=googletag.defineSlot('/8095840/.2_8313.4_androidguys.com_tier1',[300,250],'div-gpt-ad-1487237564018-0').addService(googletag.pubads());var slot8315=googletag.defineSlot('/8095840/.2_8315.5_androidguys.com_tier1',[320,50],'div-gpt-ad-1487238572908-0').addService(googletag.pubads());var refreshSlots=[slot8313,slot8309,slot8312,slot8315];setInterval(function RefreshBids(){console.log('Refresh Bids Initialized');pbjs.que.push(function(){pbjs.requestBids({timeout:PREBID_TIMEOUT,adUnitCodes:['div-gpt-ad-1487237318659-0','div-gpt-ad-1487239195458-0','div-gpt-ad-1487237564018-0','div-gpt-ad-1487238572908-0'],bidsBackHandler:function(){console.log('RefreshBids.bidsBackHandler',refreshSlots);pbjs.setTargetingForGPTAsync(['div-gpt-ad-1487237318659-0','div-gpt-ad-1487239195458-0','div-gpt-ad-1487237564018-0','div-gpt-ad-1487238572908-0']);console.log('Refresh Ads');googletag.pubads().refresh(refreshSlots);}});});},90000);googletag.enableServices();});</script> <meta name="google-site-verification" content="I1ofvKzj9-PCcV8x_fGxRnSAKy1UcgbjbyD-zzQRmZA" /> <script type="text/javascript">(function(){function async_load(script_url){var protocol=('https:'==document.location.protocol?'https://':'http://');var s=document.createElement('script');s.src=protocol+script_url;var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);}
bm_website_code='FA8119ABF3BC4F52';jQuery(document).ready(function(){async_load('asset.pagefair.com/measure.min.js')});})();</script> <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script> <style>div[id*='34623'] {
height:auto;
overflow:auto;
}

@media (width:716px) {
div[id*='34623'] {
width:695px !important;
}
}

@media (width:660px) {
div[id*='34623'] {
width:639px !important;
}
}

@media (width:432px) {
div[id*='34623'] {
width:411px !important;
}
}</style></head><body class="post-template-default single single-post postid-147994 single-format-standard ultimate-raspberry-pi-ebook-bundle single_template_8 wpb-js-composer js-comp-ver-5.5.4 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.facebook.com/androidguys" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.instagram.com/androidguys" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.androidguys.com/feed/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.twitter.com/androidguys" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-main-navigation-container"><ul id="menu-main-navigation" class="td-mobile-main-menu"><li id="menu-item-79191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-79191"><a href="https://www.androidguys.com/category/news/">News</a></li><li id="menu-item-140005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-140005"><a href="https://www.androidguys.com/category/tips-tools/">Tips &#038; Tools</a></li><li id="menu-item-101200" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-101200"><a href="https://www.androidguys.com/category/reviews/">Reviews</a></li><li id="menu-item-114857" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-114857"><a href="https://www.androidguys.com/category/deals/">Deals</a></li><li id="menu-item-133384" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-133384"><a href="https://www.androidguys.com/category/best/">The Best</a></li><li id="menu-item-101731" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-101731"><a href="https://www.androidguys.com/category/featured/">Featured</a></li><li id="menu-item-114860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114860"><a href="https://www.androidguys.com/category/featured/opinion/">Opinion</a></li><li id="menu-item-138839" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138839"><a href="https://www.androidguys.com/category/podcast/">Podcast</a></li></ul></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.androidguys.com/"><div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob"></div></div></div><div id="td-outer-wrap"><div class="td-header-wrap td-header-style-3"><div class="td-header-top-menu-full"><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-4"><div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.facebook.com/androidguys" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.instagram.com/androidguys" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.androidguys.com/feed/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.twitter.com/androidguys" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class="td-header-sp-top-menu"><div class="menu-top-container"><ul id="menu-follow-us" class="top-header-menu"><li id="menu-item-117019" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-117019"><a href="http://deals.androidguys.com">Shop and Save!</a></li><li id="menu-item-146447" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-146447"><a href="https://www.androidguys.com/category/promoted-deals/">Promoted Deals</a></li><li id="menu-item-146448" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-146448"><a href="https://www.androidguys.com/category/promoted-news/">Promoted News</a></li><li id="menu-item-133383" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-133383"><a href="https://www.androidguys.com/category/giveaways/">Giveaways</a></li><li id="menu-item-110048" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-110048"><a href="https://www.androidguys.com/about/">About</a><ul class="sub-menu"><li id="menu-item-119705" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-119705"><a href="https://www.androidguys.com/jobs/">Jobs</a></li></ul></li><li id="menu-item-110042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-110042"><a href="https://www.androidguys.com/contact/">Contact</a><ul class="sub-menu"><li id="menu-item-134342" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-134342"><a href="https://www.androidguys.com/request-app-review/">Request App or Game Review</a></li><li id="menu-item-110044" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-110044"><a href="https://www.androidguys.com/sponsorship-opportunities/">Advertising and Sponsorship</a></li><li id="menu-item-110043" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-110043"><a href="https://www.androidguys.com/sponsored-review/">Sponsored App &#038; Game Review</a></li><li id="menu-item-124421" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-124421"><a href="https://www.androidguys.com/sponsored-product-review/">Sponsored Product Review</a></li></ul></li></ul></div></div></div></div></div><div class="td-banner-wrap-full"><div class="td-container td-header-row td-header-header"><div class="td-header-sp-logo">
<a class="td-main-logo" href="https://www.androidguys.com/">
<img class="td-retina-data" data-retina="https://www.androidguys.com/wp-content/uploads/2017/03/ag_logo_544_180.png" src="https://www.androidguys.com/wp-content/uploads/2018/06/ag_logo_400-60.jpg" alt="AndroidGuys" />
<span class="td-visual-hidden">AndroidGuys</span>
</a></div><div class="td-header-sp-recs"><div class="td-header-rec-wrap"><div class="td-a-rec td-a-rec-id-header  "><div class="td-visible-desktop"><div id='div-gpt-ad-1487237318659-0' style='height:90px; width:728px;'> <script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1487237318659-0');});</script> </div></div><div class="td-visible-phone"><div id='div-gpt-ad-1487238572908-0' style='height:50px; width:320px;'> <script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1487238572908-0');});</script> </div></div></div></div></div></div></div><div class="td-header-menu-wrap-full"><div class="td-header-menu-wrap"><div class="td-container td-header-row td-header-main-menu black-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-disable" href="https://www.androidguys.com/">
<img class="td-retina-data" data-retina="https://www.androidguys.com/wp-content/uploads/2016/03/ag_280_96.png" src="https://www.androidguys.com/wp-content/uploads/2016/03/ag_140_48.png" alt="AndroidGuys" />
</a>
<a class="td-header-logo td-sticky-disable" href="https://www.androidguys.com/">
<img class="td-retina-data" data-retina="https://www.androidguys.com/wp-content/uploads/2017/03/ag_logo_544_180.png" src="https://www.androidguys.com/wp-content/uploads/2018/06/ag_logo_400-60.jpg" alt="AndroidGuys" />
</a></div><div class="menu-main-navigation-container"><ul id="menu-main-navigation-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-79191"><a href="https://www.androidguys.com/category/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-140005"><a href="https://www.androidguys.com/category/tips-tools/">Tips &#038; Tools</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-101200"><a href="https://www.androidguys.com/category/reviews/">Reviews</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-114857"><a href="https://www.androidguys.com/category/deals/">Deals</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-133384"><a href="https://www.androidguys.com/category/best/">The Best</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-101731"><a href="https://www.androidguys.com/category/featured/">Featured</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-114860"><a href="https://www.androidguys.com/category/featured/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-138839"><a href="https://www.androidguys.com/category/podcast/">Podcast</a></li></ul></div></div><div class="td-search-wrapper"><div id="td-top-search"><div class="header-search-wrap"><div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div></div></div></div><div class="header-search-wrap"><div class="dropdown header-search"><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.androidguys.com/"><div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div></div><article id="post-147994" class="td-post-template-8 post-147994 post type-post status-publish format-standard has-post-thumbnail hentry category-deals tag-code-for-raspberry-pi tag-pi tag-raspberry-pi" itemscope itemtype="https://schema.org/Article"><div class="td-post-header td-image-gradient-style8"><div class="td-crumb-container"><div class="entry-crumbs" itemscope itemtype="http://schema.org/BreadcrumbList"><span class="td-bred-first"><a href="https://www.androidguys.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemprop="itemListElement" itemtype="http://schema.org/ListItem">
<a title="View all posts in Deal of the Day" class="entry-crumb" itemscope itemprop="item" itemtype="http://schema.org/Thing" href="https://www.androidguys.com/category/deals/">
<span itemprop="name">Deal of the Day</span> </a><meta itemprop="position" content="1"></span></div></div><div class="td-post-header-holder"><header class="td-post-title"><ul class="td-category"></ul><h1 class="entry-title">The Ultimate Raspberry Pi eBook bundle is yours for $20 today</h1><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.androidguys.com/author/androidguys/">AndroidGuys</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-11-13T15:00:21+00:00">November 13, 2018</time></span></div></header></div></div><div class="td-post-template-8-box"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12 td-main-content" role="main"><div class="td-ss-main-content"><div class="td-post-content"><div class="td-a-rec td-a-rec-id-content_top  td-rec-hide-on-m td-rec-hide-on-tl td-rec-hide-on-tp td-rec-hide-on-p "></div><p>Listen up, tinkerers and hackers. The AndroidGuys Deals Store is offering a fantastic <a href="https://deals.androidguys.com/sales/the-ultimate-raspberry-pi-ebook-bundle?utm_source=androidguys.com&amp;utm_medium=referral&amp;utm_campaign=the-ultimate-raspberry-pi-ebook-bundle_111318&amp;utm_term=scsf-305840&amp;utm_content=a0x1a000003oH6c&amp;scsonar=1" target="_blank" rel="noopener">bundle of training on Raspberry Pi</a>. Worth nearly $125 in total, this is a four-part eBook kit that offers up some 1,500 pages of education that&#8217;s available anytime you want &#8212; for as long as you live.</p><h3>What&#8217;s a Raspberry Pi and why do I care?</h3><p>The credit card-sized, next-gen microcomputer is an incredibly cool device that can be tapped for all sorts of potential. It has kicked off a new age of discovery and development for people of all ages.</p><p>Remember those sci-fi movies and TV shows that promised smart homes with remotely controlled lights and sensors? That&#8217;s no longer a fantasy; it is common among many of the newer houses and offices being designed. A lot of what can be done with building and programming such tech revolves around a Raspberry Pi.</p><p>Our bundle teaches you everything you need to get started and into automating your home or other projects. There&#8217;s all sorts of cool stuff you can do with a Raspberry Pi, including a weather station, photo booth, streaming internet radio, and even your own Amazon Echo.</p><p>Isn&#8217;t it time you learned how to harness that tech for yourself?</p><p>Our <a href="https://deals.androidguys.com/sales/the-ultimate-raspberry-pi-ebook-bundle?utm_source=androidguys.com&amp;utm_medium=referral&amp;utm_campaign=the-ultimate-raspberry-pi-ebook-bundle_111318&amp;utm_term=scsf-305840&amp;utm_content=a0x1a000003oH6c&amp;scsonar=1" target="_blank" rel="noopener">eBook bundles includes</a> Raspberry Pi for Secret Agents, Raspberry Pi 3 Cookbook for Python Programmers, Raspberry Pi for Python Programmers Cookbook: Second Edition; and Build Supercomputers with Raspberry Pi 3. Each book is packed chock-full of recipes for turning a Pi into practically anything.</p><p>Follow the directions put forth in these books and you&#8217;ll be able to turn a Pi into a motion detector, remote controlled robot, spy camera, media server, a whole array of cool things.</p><h3>Features</h3><ul><li>Raspberry Pi for Secret Agents</li><li>Raspberry Pi 3 Cookbook for Python Programmers</li><li>Raspberry Pi for Python Programmers Cookbook: Second Edition</li><li>Build Supercomputers with Raspberry Pi 3</li></ul><h3>Where to Buy</h3><p>You can purchase the Ultimate Raspberry Pi eBook Bundle <a href="https://deals.androidguys.com/sales/the-ultimate-raspberry-pi-ebook-bundle?utm_source=androidguys.com&amp;utm_medium=referral&amp;utm_campaign=the-ultimate-raspberry-pi-ebook-bundle_111318&amp;utm_term=scsf-305840&amp;utm_content=a0x1a000003oH6c&amp;scsonar=1" target="_blank" rel="noopener">from the AndroidGuys Deals Store for only $19.99</a>. Normally, each of these books would run about $28 or more, so take advantage of the bulk savings!</p><h3>Save even more!</h3><p>In addition to the savings above, when you buy through AndroidGuys Deals, for every $25 spent, you get $1 credit added to your account. What&#8217;s more, should you refer the deal via social media or an email that results in a purchase, you&#8217;ll earn $10 credit in your account.</p><p style="text-align: center;"><a class="vc_btn vc_btn-danger vc_btn-lg vc_btn_square " target="_blank" href="https://deals.androidguys.com/sales/the-ultimate-raspberry-pi-ebook-bundle?utm_source=androidguys.com&amp;utm_medium=referral&amp;utm_campaign=the-ultimate-raspberry-pi-ebook-bundle_111318&amp;utm_term=scsf-305840&amp;utm_content=a0x1a000003oH6c&amp;scsonar=1">Save 95!</a></p><p>If this is your <span style="text-decoration: underline;"><strong>first time buying</strong></span>, then you are also eligible for a further <span style="text-decoration: underline;"><strong>10% discount</strong></span> when you subscribe for email updates.</p><h3>How about a freebie?</h3><p>Not looking to spend any money today? That&#8217;s alright, we understand. Why not visit the <a href="https://deals.androidguys.com/free" target="_blank" rel="noopener">AndroidGuys section for freebies</a> and take something anyhow? Go ahead, grab two!</p></div><footer><div class="td-post-source-tags"><ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.androidguys.com/tag/code-for-raspberry-pi/">code for raspberry pi</a></li><li><a href="https://www.androidguys.com/tag/pi/">pi</a></li><li><a href="https://www.androidguys.com/tag/raspberry-pi/">raspberry pi</a></li></ul></div><div class="td-post-sharing td-post-sharing-bottom "><span class="td-post-share-title">SHARE</span><div class="td-default-sharing">
<a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.androidguys.com%2Fdeals%2Fultimate-raspberry-pi-ebook-bundle%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
<a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=The+Ultimate+Raspberry+Pi+eBook+bundle+is+yours+for+%2420+today&url=https%3A%2F%2Fwww.androidguys.com%2Fdeals%2Fultimate-raspberry-pi-ebook-bundle%2F&via=androidguys"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
<a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=https://www.androidguys.com/deals/ultimate-raspberry-pi-ebook-bundle/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
<a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=https://www.androidguys.com/deals/ultimate-raspberry-pi-ebook-bundle/&amp;media=https://www.androidguys.com/wp-content/uploads/2017/03/raspberry-pi-image.jpg&description=The+Ultimate+Raspberry+Pi+eBook+bundle+is+yours+for+%2420+today" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
<a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=The+Ultimate+Raspberry+Pi+eBook+bundle+is+yours+for+%2420+today%20-%20https%3A%2F%2Fwww.androidguys.com%2Fdeals%2Fultimate-raspberry-pi-ebook-bundle%2F"><i class="td-icon-whatsapp"></i></a></div></div><div class="author-box-wrap"><a href="https://www.androidguys.com/author/androidguys/"><img alt='' src='https://secure.gravatar.com/avatar/6a1a7f4af1fe5186172157d70e650932?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/6a1a7f4af1fe5186172157d70e650932?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.androidguys.com/author/androidguys/">AndroidGuys</a></span></div><div class="td-author-description">Since 2007 we have offered news and opinion around Android, the mobile space, and connected homes. We aim to help users get more from their smartphones and hope to be a valuable resource for future purchases.</div><div class="td-author-social">
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.facebook.com/androidguys" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://twitter.com/androidguys" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class="clearfix"></div></div></div> <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="AndroidGuys"></span><meta itemprop="datePublished" content="2018-11-13T15:00:21+00:00"><meta itemprop="dateModified" content="2018-11-13T14:56:26+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.androidguys.com/deals/ultimate-raspberry-pi-ebook-bundle/" /><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.androidguys.com/wp-content/uploads/2018/06/ag_logo_400-60.jpg"></span><meta itemprop="name" content="AndroidGuys"></span><meta itemprop="headline " content="The Ultimate Raspberry Pi eBook bundle is yours for $20 today"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.androidguys.com/wp-content/uploads/2017/03/raspberry-pi-image.jpg"><meta itemprop="width" content="1200"><meta itemprop="height" content="490"></span> </footer><div id="disqus_thread"></div></div></div></div></div></div>
</article><div class="td-footer-wrapper"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span12"></div></div></div><div class="td-footer-bottom-full"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.androidguys.com/"><img class="td-retina-data" src="https://www.androidguys.com/wp-content/uploads/2018/06/ag_logo_400-60.jpg" data-retina="https://www.androidguys.com/wp-content/uploads/2017/03/ag_logo_544_180.png" alt="AndroidGuys" title="" /></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Now in our 11th year, AndroidGuys loves to provide readers with the latest news and rumors as well as reviews, opinion pieces, and tools to get more from your Android. You have an awesome phone in your pocket; let us help you get more from it.<div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#cebebcabbdbd8eafa0aabca1a7aaa9bbb7bde0ada1a3"><span class="__cf_email__" data-cfemail="ea9a988f9999aa8b848e9885838e8d9f9399c4898587">[email&#160;protected]</span></a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.facebook.com/androidguys" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.instagram.com/androidguys" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.androidguys.com/feed/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.twitter.com/androidguys" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></aside></div></div></div></div></div><div class="td-sub-footer-container"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span7 td-sub-footer-menu"></div><div class="td-pb-span5 td-sub-footer-copy">
&copy;</div></div></div></div></div> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src="https://apis.google.com/js/plusone.js"></script> <script>var amzn_ps_tracking_id="andro0eb-20";var amzn_ps_instance_id="3b2080bb-084f-4f79-9eca-229a944a5a5f";</script> <script async="true" type="text/javascript" src="//ps-us.amazon-adsystem.com/scripts/US/studio.js" charset="UTF-8"></script> <script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=f8a9d144-449a-4897-8c59-9d53e8826517"></script> <script type="application/javascript" src="https://www9.smartadserver.com/ac?out=js&nwid=1331&siteid=94704&pgname=.2_11159.3_androidguys.com_tier1_/hi/&fmtid=44627&tgt=[sas_target]&visit=m&tmstp=[timestamp]&clcturl=[countgo]"></script> <script type="application/javascript" src="https://www9.smartadserver.com/ac?out=js&nwid=1331&siteid=94704&pgname=.2_11160.5_androidguys.com_tier1_/hi/&fmtid=44627&tgt=[sas_target]&visit=m&tmstp=[timestamp]&clcturl=[countgo]"></script> <a style="cursor:pointer" onclick="window.__cmp(&quot;displayConsentUi&quot;)">Change Ad Consent</a> <script src="//s.skimresources.com/js/75515X1525641.skimlinks.js"></script> <script data-cfasync="false" type="text/javascript">(function(){var s=document.createElement('script');s.type='text/javascript';s.async=true;s.src='//nextmillennium.liqwid.net/?key=D85D-A6F1-B041-B88A';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);})();</script> 
<style type="text/css" media="screen">@media (min-width: 768px) and (max-width: 1018px) {
.td-pb-span8 {
width:440px;
}

.td-pb-span4 {
width:328px;
}
}</style> <script type="text/javascript">/*<![CDATA[*/function getBrowserSize(){var w,h;if(typeof window.innerWidth!='undefined')
{w=window.innerWidth;h=window.innerHeight;}
else if(typeof document.documentElement!='undefined'&&typeof document.documentElement.clientWidth!='undefined'&&document.documentElement.clientWidth!==0)
{w=document.documentElement.clientWidth;h=document.documentElement.clientHeight;}
else{w=document.body.clientWidth;h=document.body.clientHeight;}
return{'width':w,'height':h};}
if(parseInt(getBrowserSize().width)<=768){var spots=document.getElementsByClassName("td-visible-desktop");for(let i=0;i<spots.length;i++){spots[i].remove();}}
else{var spots=document.getElementsByClassName("td-visible-phone");for(let i=0;i<spots.length;i++){spots[i].remove();}}/*]]>*/</script><script type='text/javascript'>var countVars={"disqusShortname":"androidguys"};</script> <script type='text/javascript' src='https://www.androidguys.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script> <script type='text/javascript'>var embedVars={"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"147994 https:\/\/www.androidguys.com\/?p=147994","disqusShortname":"androidguys","disqusTitle":"The Ultimate Raspberry Pi eBook bundle is yours for $20 today","disqusUrl":"https:\/\/www.androidguys.com\/deals\/ultimate-raspberry-pi-ebook-bundle\/","postId":"147994"};</script> <script type='text/javascript' src='https://www.androidguys.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script> <script type='text/javascript' src='https://www.androidguys.com/wp-content/themes/Newspaper2/js/tagdiv_theme.js?ver=7.6.1'></script> <script type='text/javascript' src='https://www.androidguys.com/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script> <script type='text/javascript' src='https://www.androidguys.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=3.0.0-beta.1'></script> <script type='text/javascript' src='https://www.androidguys.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script> <script>/*<![CDATA[*/if('undefined'!==typeof window.tdBackstr){(function(){var wrapper_image_jquery_obj=jQuery('<div class=\'backstretch\'></div>');var image_jquery_obj=jQuery('<img class=\'td-backstretch not-parallax\' src=\'https://www.androidguys.com/wp-content/uploads/2017/03/raspberry-pi-image.jpg\'>');wrapper_image_jquery_obj.append(image_jquery_obj);jQuery('body').prepend(wrapper_image_jquery_obj);var td_backstr_item=new tdBackstr.item();td_backstr_item.wrapper_image_jquery_obj=wrapper_image_jquery_obj;td_backstr_item.image_jquery_obj=image_jquery_obj;tdBackstr.add_item(td_backstr_item);})();}
(function(){var html_jquery_obj=jQuery('html');if(html_jquery_obj.length&&(html_jquery_obj.is('.ie8')||html_jquery_obj.is('.ie9'))){var path='https://www.androidguys.com/wp-content/themes/Newspaper2/style.css';jQuery.get(path,function(data){var str_split_separator='#td_css_split_separator';var arr_splits=data.split(str_split_separator);var arr_length=arr_splits.length;if(arr_length>1){var dir_path='https://www.androidguys.com/wp-content/themes/Newspaper2';var splited_css='';for(var i=0;i<arr_length;i++){if(i>0){arr_splits[i]=str_split_separator+' '+arr_splits[i];}
var formated_str=arr_splits[i].replace(/\surl\(\'(?!data\:)/gi,function regex_function(str){return' url(\''+dir_path+'/'+str.replace(/url\(\'/gi,'').replace(/^\s+|\s+$/gm,'');});splited_css+="<style></style>";}
var td_theme_css=jQuery('link#td-theme-css');if(td_theme_css.length){td_theme_css.after(splited_css);}}});}})();/*]]>*/</script> </body></html>