<!doctype html >
<!--[if IE 8]><html
class=ie8 lang=en> <![endif]-->
<!--[if IE 9]><html
class=ie9 lang=en> <![endif]-->
<!--[if gt IE 8]><!--><html lang=en-US xmlns:og=http://ogp.me/ns# xmlns:fb=http://ogp.me/ns/fb#> <!--<![endif]--><head><meta charset=UTF-8><meta name=viewport content="width=device-width, initial-scale=1.0"><link rel=pingback href=https://www.androidguys.com/xmlrpc.php><meta property=og:image content=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_03.jpg><meta name=author content="Scott Webster"><link rel=icon type=image/png href=https://www.androidguys.com/wp-content/uploads/2018/04/ag-favicon-2018.png><title>GoCube review</title><meta name=description content="The GoCube is a modern take on the popular Rubik&#039;s Cube puzzle as it pairs to your phone, challenges you to be a better player, and more."><link rel=canonical href=https://www.androidguys.com/reviews/accessory-reviews/gocube/> <script type=application/ld+json class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.androidguys.com/#organization","name":"AndroidGuys","url":"https://www.androidguys.com/","sameAs":["http://www.facebook.com/androidguys","http://www.instagram.com/androidguys","https://twitter.com/androidguys"]},{"@type":"WebSite","@id":"https://www.androidguys.com/#website","url":"https://www.androidguys.com/","name":"AndroidGuys","publisher":{"@id":"https://www.androidguys.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.androidguys.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.androidguys.com/reviews/accessory-reviews/gocube/#webpage","url":"https://www.androidguys.com/reviews/accessory-reviews/gocube/","inLanguage":"en-US","name":"GoCube review","isPartOf":{"@id":"https://www.androidguys.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.androidguys.com/reviews/accessory-reviews/gocube/#primaryimage","url":"https://www.androidguys.com/wp-content/uploads/2020/07/gocube_03.jpg","caption":""},"primaryImageOfPage":{"@id":"https://www.androidguys.com/reviews/accessory-reviews/gocube/#primaryimage"},"datePublished":"2020-07-10T20:00:48+00:00","dateModified":"2020-07-10T19:43:27+00:00","description":"The GoCube is a modern take on the popular Rubik's Cube puzzle as it pairs to your phone, challenges you to be a better player, and more."},{"@type":"NewsArticle","@id":"https://www.androidguys.com/reviews/accessory-reviews/gocube/#article","isPartOf":{"@id":"https://www.androidguys.com/reviews/accessory-reviews/gocube/#webpage"},"author":{"@id":"https://www.androidguys.com/author/admin/#author","name":"Scott Webster"},"publisher":{"@id":"https://www.androidguys.com/#organization"},"headline":"GoCube review","datePublished":"2020-07-10T20:00:48+00:00","dateModified":"2020-07-10T19:43:27+00:00","commentCount":0,"mainEntityOfPage":"https://www.androidguys.com/reviews/accessory-reviews/gocube/#webpage","image":{"@id":"https://www.androidguys.com/reviews/accessory-reviews/gocube/#primaryimage"},"keywords":"gocube","articleSection":"Accessory Reviews","copyrightYear":"2020","copyrightHolder":{"@id":"https://www.androidguys.com#organization"}},{"@type":"Person","@id":"https://www.androidguys.com/author/admin/#author","name":"Scott Webster","image":{"@type":"ImageObject","@id":"https://www.androidguys.com/#personlogo","url":"https://secure.gravatar.com/avatar/3894ccc0479ba00bf16da211b9e352a7?s=96&d=mm&r=g","caption":"Scott Webster"},"description":"In addition to smartphones and mobile gadgets, Scott has a deep appreciation for film, music, and sunflower seeds. A husband and father, he likes spending down time riding his mountain bike or binge-watching TV. Scott has overseen the day-to-day activities of AndroidGuys since 2007.","sameAs":["https://twitter.com/http://www.twitter.com/swebster77"]}]}</script> <link rel=dns-prefetch href=//fonts.googleapis.com><link rel=dns-prefetch href=//s.w.org><link rel=alternate type=application/rss+xml title="AndroidGuys &raquo; Feed" href=https://www.androidguys.com/feed/><link rel=alternate type=application/rss+xml title="AndroidGuys &raquo; Comments Feed" href=https://www.androidguys.com/comments/feed/><link rel=alternate type=application/rss+xml title="AndroidGuys &raquo; GoCube review Comments Feed" href=https://www.androidguys.com/reviews/accessory-reviews/gocube/feed/> <script type=text/javascript>window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.androidguys.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.7"}};!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type=text/css>img.wp-smiley,img.emoji {
display:inline !important;
border:none !important;
box-shadow:none !important;
height:1em !important;
width:1em !important;
margin:0 .07em!important;
vertical-align:-.1em !important;
background:none !important;
padding:0!important;
}</style><link rel=stylesheet id=wp-block-library-css href='https://www.androidguys.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.7' type=text/css media=all><link crossorigin=anonymous rel=stylesheet id=google_font_open_sans-css href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=5.2.7' type=text/css media=all><link crossorigin=anonymous rel=stylesheet id=google_font_roboto-css href='https://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=5.2.7' type=text/css media=all><link crossorigin=anonymous rel=stylesheet id=google-fonts-style-css href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C700&#038;ver=5.2.7' type=text/css media=all><link rel=stylesheet id=js_composer_front-css href='https://www.androidguys.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.5.4' type=text/css media=all><link rel=stylesheet id=td-theme-css href='https://www.androidguys.com/wp-content/themes/Newspaper2/style.css?ver=7.6.1' type=text/css media=all> <script type=text/javascript src='https://www.androidguys.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type=text/javascript src='https://www.androidguys.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <link rel=https://api.w.org/ href=https://www.androidguys.com/wp-json/><link rel=EditURI type=application/rsd+xml title=RSD href=https://www.androidguys.com/xmlrpc.php?rsd><link rel=wlwmanifest type=application/wlwmanifest+xml href=https://www.androidguys.com/wp-includes/wlwmanifest.xml><meta name=generator content="WordPress 5.2.7"><link rel=shortlink href='https://www.androidguys.com/?p=163281'><link rel=alternate type=application/json+oembed href="https://www.androidguys.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidguys.com%2Freviews%2Faccessory-reviews%2Fgocube%2F"><link rel=alternate type=text/xml+oembed href="https://www.androidguys.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidguys.com%2Freviews%2Faccessory-reviews%2Fgocube%2F&#038;format=xml">
<!--[if lt IE 9]><script src=https://html5shim.googlecode.com/svn/trunk/html5.js></script><![endif]--><meta name=generator content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress.">
<!--[if lte IE 9]><link
rel=stylesheet type=text/css href=https://www.androidguys.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css media=screen><![endif]--><link rel=amphtml href=https://www.androidguys.com/reviews/accessory-reviews/gocube/amp/>
<script>var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=false;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop='';}
(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10';}
if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11';}
if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios';}
var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android';}
if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x';}
if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome';}
if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox';}
if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari';}
if(-1!==navigator.userAgent.indexOf('IEMobile')){htmlTag.className+=' td-md-is-iemobile';}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id];},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;},get:function(resource_id){return tdLocalCache.data[resource_id];},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData;}};})();var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var tds_general_modal_image="yes";var td_ajax_url="https:\/\/www.androidguys.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.6.1";var td_get_template_directory_uri="https:\/\/www.androidguys.com\/wp-content\/themes\/Newspaper2";var tds_snap_menu="snap";var tds_logo_on_sticky="";var tds_header_style="4";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="";var tds_more_articles_on_post_time_to_wait="1";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#33b5e5";var tds_smart_sidebar="";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var td_ad_background_click_link="";var td_ad_background_click_target="";</script> <style>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</style> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga');ga('create','UA-2973238-3','auto');ga('send','pageview');</script><link rel=icon href=https://www.androidguys.com/wp-content/uploads/2018/06/cropped-AG-Logo-Standalone_sq-white-32x32.png sizes=32x32><link rel=icon href=https://www.androidguys.com/wp-content/uploads/2018/06/cropped-AG-Logo-Standalone_sq-white-192x192.png sizes=192x192><link rel=apple-touch-icon-precomposed href=https://www.androidguys.com/wp-content/uploads/2018/06/cropped-AG-Logo-Standalone_sq-white-180x180.png><meta name=msapplication-TileImage content=https://www.androidguys.com/wp-content/uploads/2018/06/cropped-AG-Logo-Standalone_sq-white-270x270.png>
<noscript><style type=text/css>.wpb_animate_when_almost_visible {
opacity:1;
}</style></noscript><meta property=og:locale content=en_US><meta property=og:site_name content=AndroidGuys><meta property=og:title content="GoCube review"><meta property=og:url content=https://www.androidguys.com/reviews/accessory-reviews/gocube/><meta property=og:type content=article><meta property=og:description content="The GoCube is a modern take on the popular Rubik&#039;s Cube puzzle as it pairs to your phone, challenges you to be a better player, and more."><meta property=og:image content=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_03.jpg><meta property=og:image:url content=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_03.jpg><meta property=og:image:secure_url content=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_03.jpg><meta property=article:published_time content=2020-07-10T16:00:48-04:00><meta property=article:modified_time content=2020-07-10T15:43:27-04:00><meta property=og:updated_time content=2020-07-10T15:43:27-04:00><meta property=article:section content="Accessory Reviews"><meta itemprop=name content="GoCube review"><meta itemprop=headline content="GoCube review"><meta itemprop=description content="The GoCube is a modern take on the popular Rubik&#039;s Cube puzzle as it pairs to your phone, challenges you to be a better player, and more."><meta itemprop=image content=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_03.jpg><meta itemprop=datePublished content=2020-07-10><meta itemprop=dateModified content=2020-07-10T15:43:27-04:00><meta itemprop=author content="Scott Webster"><meta name=twitter:title content="GoCube review"><meta name=twitter:url content=https://www.androidguys.com/reviews/accessory-reviews/gocube/><meta name=twitter:description content="The GoCube is a modern take on the popular Rubik&#039;s Cube puzzle as it pairs to your phone, challenges you to be a better player, and more."><meta name=twitter:image content=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_03.jpg><meta name=twitter:card content=summary_large_image><meta name=twitter:creator content=@http://www.twitter.com/swebster77><meta name=twitter:site content=@androidguys>
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga');ga('create','UA-2973238-3','auto');ga('send','pageview');</script> <script src=https://static.swappa.com/static/widget/widget.min.js data-affiliate-code=scottwebster async></script> <script type=text/javascript src=https://s.skimresources.com/js/75515X1525641.skimlinks.js></script> <script type=text/javascript src=https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js async=true></script> <script type=application/ld+json>{"@context":"http://schema.org","@type":"Organization","name":"AndroidGuys","url":"http://www.androidguys.com","sameAs":["http://www.facebook.com/androidguys","http://instagram.com/androidguys","http://twitter.com/androidguys"]}</script> <script type=text/javascript data-cfasync=false src=//dsh7ky7308k4b.cloudfront.net/publishers/androidguyscom.min.js?v6></script> <script async=async data-cfasync=false src=https://www.googletagservices.com/tag/js/gpt.js></script> <script data-cfasync=false>googletag.cmd.push(function(){googletag.defineSlot('/8095840/.2_A.36993.46_androidguys.com_tier1',[1,1],'div-gpt-ad-1584607354475-0').addService(googletag.pubads());googletag.pubads().disableInitialLoad();googletag.enableServices();});</script> <script data-cfasync=false>var pgSlot35113;googletag.cmd.push(function(){if(window.innerWidth>=1140){googletag.defineSlot('/8095840/.2_11396.46_androidguys.com_tier1',[700,600],'div-gpt-ad-1559639732283-0').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_A.37008.4_androidguys.com_tier1',[300,250],'div-gpt-ad-androidguyscom37008').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_A.37009.4_androidguys.com_tier1',[300,250],'div-gpt-ad-androidguyscom37009').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_A.37010.7_androidguys.com_tier1',[[300,250],[160,600],[300,600]],'div-gpt-ad-androidguyscom37010').addService(googletag.pubads());}
else{googletag.defineSlot('/8095840/.2_8320.4_androidguys.com_tier1',[300,250],'div-gpt-ad-1487238677738-0').addService(googletag.pubads());}
if(window.innerWidth<766){pgSlot35113=googletag.defineSlot('/8095840/.2_A.35113.5_androidguys.com_tier1',[320,50],'div-gpt-ad-androidguyscom35113').addService(googletag.pubads());}
googletag.defineSlot('/8095840/.2_8317.5_androidguys.com_tier1',[320,50],'div-gpt-ad-1487238631958-0').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_8318.7_androidguys.com_tier1',[300,600],'div-gpt-ad-1487256038713-0').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_8319.4_androidguys.com_tier1',[300,250],'div-gpt-ad-1487238658175-0').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_11211.4_androidguys.com_tier1',[300,250],'div-gpt-ad-1499250035802-0').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_A.35103.3_androidguys.com_tier1',[728,90],'div-gpt-ad-androidguyscom35103').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_A.35109.3_androidguys.com_tier1',[728,90],'div-gpt-ad-androidguyscom35109').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_A.35110.3_androidguys.com_tier1',[728,90],'div-gpt-ad-androidguyscom35110').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_A.35114.5_androidguys.com_tier1',[320,50],'div-gpt-ad-androidguyscom35114').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_A.35115.5_androidguys.com_tier1',[320,50],'div-gpt-ad-androidguyscom35115').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_A.34621.46_androidguys.com_tier1',[1,1],'div-gpt-ad-1586268470998-0').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_A.37012.5_androidguys.com_tier1',[[320,50],[300,250],[336,280]],'div-gpt-ad-androidguyscom37012').addService(googletag.pubads());googletag.defineSlot('/8095840/.2_A.37011.3_androidguys.com_tier1',[[728,90],[970,90],[970,250]],'div-gpt-ad-androidguyscom37011').addService(googletag.pubads());googletag.pubads().disableInitialLoad();googletag.pubads().collapseEmptyDivs();googletag.enableServices();});</script> <script type=text/javascript src=//s.ntv.io/serve/load.js async></script> <style>div[id*='34623'] {
height:auto;
overflow:auto;
}

@media (width:716px) {
div[id*='34623'] {
width:695px !important;
}
}

@media (width:660px) {
div[id*='34623'] {
width:639px !important;
}
}

@media (width:432px) {
div[id*='34623'] {
width:411px !important;
}
}</style> <script src=https://pubgalaxy-com.videoplayerhub.com/gallery.js></script> <style>.qc-cmp-persistent-link {
left:0 !important;
right:auto !important;
}

.tg-active-ad::before {
display:block;
content:'Advertisements';
position:absolute;
top:-22px;
left:110px;
}

#cnx-fullScreen-container:not(.cnx-floating)::before,#cnx-video-image::before,.cnx-floating::before {
display:block;
content:'Advertisements';
position:absolute;
top:-24px;
left:0;
width:100% !important;
text-align:center !important;
}

#cnx-video-image::before {
top:-28px;
color:#000;
font-weight:500;
font-size:.9rem;
}

.cnx-floating {
margin-bottom:15px;
}</style></head><body class="post-template-default single single-post postid-163281 single-format-standard gocube wpb-js-composer js-comp-ver-5.5.4 vc_responsive td-boxed-layout" itemscope=itemscope itemtype=https://schema.org/WebPage><div class=td-scroll-up><i class=td-icon-menu-up></i></div><div class=td-menu-background></div><div id=td-mobile-nav><div class=td-mobile-container><div class=td-menu-socials-wrap><div class=td-menu-socials>
<span class=td-social-icon-wrap>
<a target=_blank href="https://www.facebook.com/androidguys" title=Facebook>
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class=td-social-icon-wrap>
<a target=_blank href="https://www.instagram.com/androidguys" title=Instagram>
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class=td-social-icon-wrap>
<a target=_blank href="https://www.androidguys.com/feed" title=RSS>
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class=td-social-icon-wrap>
<a target=_blank href="https://www.twitter.com/androidguys" title=Twitter>
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class=td-mobile-close>
<a href=#><i class=td-icon-close-mobile></i></a></div></div><div class=td-mobile-content><div class=menu-main-navigation-container><ul id=menu-main-navigation class=td-mobile-main-menu><li id=menu-item-79191 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-79191"><a href=https://www.androidguys.com/category/news/>News</a></li><li id=menu-item-114857 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114857"><a href=https://www.androidguys.com/category/deals/>Deals</a></li><li id=menu-item-101200 class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-101200"><a href=https://www.androidguys.com/category/reviews/>Reviews</a></li><li id=menu-item-154506 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154506"><a href=https://www.androidguys.com/category/best/>The Best</a></li><li id=menu-item-158741 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158741"><a href=https://www.androidguys.com/carrier-guides/>Carrier Guides</a></li><li id=menu-item-151141 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-151141"><a href=https://www.androidguys.com/about/>About<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-151142 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151142"><a href=https://www.androidguys.com/jobs/>Write for us!</a></li></ul></li><li id=menu-item-151144 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-151144"><a href=https://www.androidguys.com/contact/>Contact<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-151143 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151143"><a href=https://www.androidguys.com/sponsorship-opportunities/>Advertising and Sponsorship Opportunities</a></li><li id=menu-item-151145 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151145"><a href=https://www.androidguys.com/request-app-review/>Request App or Game Review</a></li><li id=menu-item-151146 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151146"><a href=https://www.androidguys.com/sponsored-review/>Promoted App &#038; Game Reviews</a></li><li id=menu-item-151147 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151147"><a href=https://www.androidguys.com/sponsored-product-review/>Promoted Product Reviews</a></li></ul></li></ul></div></div></div></div><div class=td-search-background></div><div class=td-search-wrap-mob><div class=td-drop-down-search aria-labelledby=td-header-search-button><form method=get class=td-search-form action=https://www.androidguys.com/><div class=td-search-close>
<a href=#><i class=td-icon-close-mobile></i></a></div><div role=search class=td-search-input>
<span>Search</span>
<input id=td-header-search-mob type=text value name=s autocomplete=off></div></form><div id=td-aj-search-mob></div></div></div><div id=td-outer-wrap><div class="td-header-wrap td-header-style-4"><div class=td-header-top-menu-full><div class="td-container td-header-row td-header-top-menu"><div class=top-bar-style-4><div class=td-header-sp-top-widget>
<span class=td-social-icon-wrap>
<a target=_blank href="https://www.facebook.com/androidguys" title=Facebook>
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class=td-social-icon-wrap>
<a target=_blank href="https://www.instagram.com/androidguys" title=Instagram>
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class=td-social-icon-wrap>
<a target=_blank href="https://www.androidguys.com/feed" title=RSS>
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class=td-social-icon-wrap>
<a target=_blank href="https://www.twitter.com/androidguys" title=Twitter>
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class=td-header-sp-top-menu></div></div></div></div><div class=td-banner-wrap-full><div class="td-header-container td-header-row td-header-header"><div class=td-header-sp-recs><div class=td-header-rec-wrap><div class="td-a-rec td-a-rec-id-header  "><div style="width:100%; text-align:center; margin:0"><span>Advertisements</span></div><div class=td-visible-desktop style="height:90px; margin-top:5px;"><div id=div-gpt-ad-androidguyscom37011 style='min-width: 728px;'> <script data-cfasync=false>googletag.cmd.push(function(){googletag.display('div-gpt-ad-androidguyscom37011');});</script> </div><span class=bt-uid-tg data-uid=5c2fcd2c81-228 style='display: none !important'></span></div><div class=td-visible-phone style=min-height:50px><div id=div-gpt-ad-androidguyscom37012 style='margin-bottom: 28px'> <script data-cfasync=false>googletag.cmd.push(function(){googletag.display('div-gpt-ad-androidguyscom37012');});</script> </div></div></div></div></div></div></div><div class=td-header-menu-wrap-full><div class=td-header-menu-wrap><div class="td-container td-header-row td-header-main-menu black-menu"><div id=td-header-menu role=navigation><div id=td-top-mobile-toggle><a href=#><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-menu">
<a class="td-mobile-logo td-sticky-disable" href=https://www.androidguys.com/>
<img class=td-retina-data data-retina=https://www.androidguys.com/wp-content/uploads/2019/03/ag_logo_green_2019_280x96.png src=https://www.androidguys.com/wp-content/uploads/2019/03/ag_logo_green_2019_140x48.png alt=AndroidGuys>
</a>
<a class="td-header-logo td-sticky-disable" href=https://www.androidguys.com/>
<img class=td-retina-data data-retina=https://www.androidguys.com/wp-content/uploads/2017/03/ag_logo_544_180.png src=https://www.androidguys.com/wp-content/uploads/2019/03/ag_logo_272_90.png alt=AndroidGuys>
<span class=td-visual-hidden>AndroidGuys</span>
</a></div><div class=menu-main-navigation-container><ul id=menu-main-navigation-1 class=sf-menu><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-79191"><a href=https://www.androidguys.com/category/news/>News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-114857"><a href=https://www.androidguys.com/category/deals/>Deals</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-normal-menu menu-item-101200"><a href=https://www.androidguys.com/category/reviews/>Reviews</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-154506"><a href=https://www.androidguys.com/category/best/>The Best</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-158741"><a href=https://www.androidguys.com/carrier-guides/>Carrier Guides</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-151141"><a href=https://www.androidguys.com/about/>About</a><ul class=sub-menu><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-151142"><a href=https://www.androidguys.com/jobs/>Write for us!</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-151144"><a href=https://www.androidguys.com/contact/>Contact</a><ul class=sub-menu><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-151143"><a href=https://www.androidguys.com/sponsorship-opportunities/>Advertising and Sponsorship Opportunities</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-151145"><a href=https://www.androidguys.com/request-app-review/>Request App or Game Review</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-151146"><a href=https://www.androidguys.com/sponsored-review/>Promoted App &#038; Game Reviews</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-151147"><a href=https://www.androidguys.com/sponsored-product-review/>Promoted Product Reviews</a></li></ul></li></ul></div></div><div class=td-search-wrapper><div id=td-top-search><div class=header-search-wrap><div class="dropdown header-search">
<a id=td-header-search-button href=# role=button class="dropdown-toggle " data-toggle=dropdown><i class=td-icon-search></i></a>
<a id=td-header-search-button-mob href=# role=button class="dropdown-toggle " data-toggle=dropdown><i class=td-icon-search></i></a></div></div></div></div><div class=header-search-wrap><div class="dropdown header-search"><div class=td-drop-down-search aria-labelledby=td-header-search-button><form method=get class=td-search-form action=https://www.androidguys.com/><div role=search class=td-head-form-search-wrap>
<input id=td-header-search type=text value name=s autocomplete=off><input class="wpb_button wpb_btn-inverse btn" type=submit id=td-header-search-top value=Search></div></form><div id=td-aj-search></div></div></div></div></div></div></div></div><div class=td-main-content-wrap><div class="td-container td-post-template-default "><div class=td-crumb-container><div class=entry-crumbs itemscope itemtype=http://schema.org/BreadcrumbList><span class=td-bred-first><a href=https://www.androidguys.com/>Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemprop=itemListElement itemtype=http://schema.org/ListItem>
<a title="View all posts in Reviews" class=entry-crumb itemscope itemprop=item itemtype=http://schema.org/Thing href=https://www.androidguys.com/category/reviews/>
<span itemprop=name>Reviews</span> </a><meta itemprop=position content="1"></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemprop=itemListElement itemtype=http://schema.org/ListItem>
<a title="View all posts in Accessory Reviews" class=entry-crumb itemscope itemprop=item itemtype=http://schema.org/Thing href=https://www.androidguys.com/category/reviews/accessory-reviews/>
<span itemprop=name>Accessory Reviews</span> </a><meta itemprop=position content="2"></span></div></div><div class=td-pb-row><div class="td-pb-span8 td-main-content" role=main><div class=td-ss-main-content><article id=post-163281 class="post-163281 post type-post status-publish format-standard has-post-thumbnail hentry category-accessory-reviews tag-gocube" itemscope itemtype=https://schema.org/Article><div class=td-post-header><ul class=td-category><li class=entry-category><a href=https://www.androidguys.com/category/reviews/accessory-reviews/>Accessory Reviews</a></li></ul><header class=td-post-title><h1 class="entry-title">GoCube review</h1><div class=td-module-meta-info><div class=td-post-author-name><div class=td-author-by>By</div> <a href=https://www.androidguys.com/author/admin/>Scott Webster</a><div class=td-author-line> -</div></div> <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-07-10T16:00:48+00:00>July 10, 2020</time></span></div></header></div><div class=td-post-content><div class=td-post-featured-image><a href=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_03.jpg data-caption><img width=696 height=392 class="entry-thumb td-modal-image" src=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_03.jpg alt title=gocube_03></a></div><p>Raise your hand if you&#8217;ve ever completed a Rubik&#8217;s Cube. Yeah, there aren&#8217;t too many of us out there who can do it, much less in a timely manner.</p><div id=div-gpt-ad-1586268470998-0 style='width: 1px; height: 1px;'> <script data-cfasync=\"false\">googletag.cmd.push(function(){googletag.display('div-gpt-ad-1586268470998-0');});</script> </div><p>On the other end of the spectrum are people who compete to see who can complete one in the quickest time possible. We&#8217;re talking a matter of seconds.</p><div class="td-a-rec td-a-rec-id-content_inline  "><div class=mm-player></div><div id=div-gpt-ad-1584607354475-0> <script data-cfasync=false>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1584607354475-0');});</script> </div></div><p><a href=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_01.jpg><img class=" td-modal-image aligncenter wp-image-163288 size-full" src=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_01.jpg alt width=1280 height=720></a></p><p>If you&#8217;ve ever asked someone to help you figure out how to solve the twisty-turny colorful square, you probably found yourself confused by what should be a few simple rules. Once you get it, you get it, but until then, it can be maddening.</p><p>The GoCube ($99) is <a href=https://getgocube.com/products/gocube-full-pack/ target=_blank rel="noopener noreferrer">smart version</a> of the popular cube that pairs to your phone. And while it can walk you through the process of solving it, there&#8217;s more at play. After its popular Indiegogo crowdfunding campaign <a href=https://www.indiegogo.com/projects/gocube-the-classic-puzzle-reinvented--2#/ target=_blank rel="noopener noreferrer">saw it raise</a> more than $1.1 million dollars, it&#8217;s available for the masses.</p><p><a href=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_05.jpg><img class=" td-modal-image aligncenter wp-image-163284 size-full" src=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_05.jpg alt width=1280 height=720></a></p><p>We&#8217;ve had one of these in the office for a few weeks, picking it up, playing with it, and trying to get better at solving the puzzle. While we&#8217;ve gotten better, we&#8217;re nowhere ready to compete against friends or family.</p><p>The first impression of the cube was that it was buttery smooth and easy to articulate. There was no ratchet-y plastic sound of the gears in the Rubik&#8217;s Cube. This was quiet stuff that moved quickly and easily.</p><p><a href=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_06.jpg><img class=" td-modal-image aligncenter wp-image-163283 size-full" src=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_06.jpg alt width=1280 height=720></a></p><p>Paired with your phone over Bluetooth, the GoCube&#8217;s sensors are able to show you exactly what each color and square looks like. Even as you flip the cube over in your hand you can see it moving in real time on your phone. And as easy as tapping a button you&#8217;ll have a literal turn-by-turn walk through of steps to solve.</p><p>If you&#8217;re already adept at completing a cube you&#8217;ll find it can time and encourage you to get better. The app makes a game out of learning how to master the GoCube and there are plenty of fun challenges to keep things fresh. Players can even play against others whether in-person or globally.</p><p><a href=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_04.jpg><img class=" td-modal-image aligncenter wp-image-163285 size-full" src=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_04.jpg alt width=1280 height=720></a></p><p>You wouldn&#8217;t know it from feeling the GoCube but there&#8217;s a battery tucked inside with the six-axis sensors. Moreover, the app provides the remaining battery level in the corner.</p><p>Charging is done by a proprietary plug that can snap directly into a particular square; the other end simply requires a USB port. Included in the box are a base and a dock that can hold your cube. If you like to show it off, or keep it on the desk, you&#8217;ll appreciate the ease in which you can charge.</p><p><a href=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_02.jpg><img class=" td-modal-image aligncenter wp-image-163287 size-full" src=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_02.jpg alt width=1280 height=720></a></p><p>We&#8217;ve enjoyed our time with the cube and have gotten better. Admittedly, we&#8217;re still to reliant on watching the phone tell us the steps instead of us learning the algorithms and ways to see it on the cube itself. Fortunately, there are plenty of steps and games left to help.</p><p><a href=https://www.androidguys.com/wp-content/uploads/2020/07/Screenshot_20200708-134433.png><img class=" td-modal-image alignleft wp-image-163290" src=https://www.androidguys.com/wp-content/uploads/2020/07/Screenshot_20200708-134433.png alt width=250 height=514></a>With a road trip coming up and two teenagers in the car we&#8217;re definitely packing the GoCube. That is, of course, provided we&#8217;re able to find it in time. For some reason, it has grown legs and began traveling between family members and friends.</p><p>In all seriousness, we appreciate the GoCube and think it&#8217;s a really cool toy or gadget. And while it does lend itself to fans of the original Rubik&#8217;s Cube and the speed cubing community, the app widens the demographic. It&#8217;s one of those &#8220;fun for all ages&#8221; sort of things.</p><p>Learn more about the GoCube at <a href=https://getgocube.com/products/gocube-full-pack/ target=_blank rel="noopener noreferrer">Particula&#8217;s website</a> where the unit appears to be on sale. For a limited time you can purchase the GoCube for just $79.95. You can also find it at Amazon where it&#8217;s also <a href=https://amzn.to/38OerjU target=_blank rel="noopener noreferrer">listed for the same price</a>.</p><div class="td-a-rec td-a-rec-id-content_bottom  "><h6>Note: Select outbound links may include affiliate tracking codes. Revenue generated from any potential purchases is used to fund AndroidGuys. <a href=https://www.androidguys.com/about/>Read our policy</a>.</h6><hr><div id=amzn-assoc-ad-e0f96624-c833-4e0b-82f8-19e1441c3c4a></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=e0f96624-c833-4e0b-82f8-19e1441c3c4a"></script></div></div><footer><div class=td-post-source-tags><ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href=https://www.androidguys.com/tag/gocube/>gocube</a></li></ul></div><div class="td-post-sharing td-post-sharing-bottom "><span class=td-post-share-title>SHARE</span><div class=td-default-sharing>
<a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.androidguys.com%2Freviews%2Faccessory-reviews%2Fgocube%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class=td-icon-facebook></i><div class=td-social-but-text>Facebook</div></a>
<a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=GoCube+review&url=https%3A%2F%2Fwww.androidguys.com%2Freviews%2Faccessory-reviews%2Fgocube%2F&via=androidguys"><i class=td-icon-twitter></i><div class=td-social-but-text>Twitter</div></a>
<a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://www.androidguys.com/reviews/accessory-reviews/gocube/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class=td-icon-googleplus></i></a>
<a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.androidguys.com/reviews/accessory-reviews/gocube/&amp;media=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_03.jpg&description=GoCube+review" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class=td-icon-pinterest></i></a>
<a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=GoCube+review%20-%20https%3A%2F%2Fwww.androidguys.com%2Freviews%2Faccessory-reviews%2Fgocube%2F"><i class=td-icon-whatsapp></i></a></div></div><div class=author-box-wrap><a href=https://www.androidguys.com/author/admin/><img alt src='https://secure.gravatar.com/avatar/3894ccc0479ba00bf16da211b9e352a7?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/3894ccc0479ba00bf16da211b9e352a7?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height=96 width=96></a><div class=desc><div class="td-author-name vcard author"><span class=fn><a href=https://www.androidguys.com/author/admin/>Scott Webster</a></span></div><div class=td-author-description>In addition to smartphones and mobile gadgets, Scott has a deep appreciation for film, music, and sunflower seeds. A husband and father, he likes spending down time riding his mountain bike or binge-watching TV. Scott has overseen the day-to-day activities of AndroidGuys since 2007.</div><div class=td-author-social>
<span class=td-social-icon-wrap>
<a target=_blank href=https://plus.google.com/109101867985252824746/posts title=Google+>
<i class="td-icon-font td-icon-googleplus"></i>
</a>
</span>
<span class=td-social-icon-wrap>
<a target=_blank href="https://www.twitter.com/swebster77" title=Twitter>
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class=clearfix></div></div></div> <span style="display: none;" itemprop=author itemscope itemtype=https://schema.org/Person><meta itemprop=name content="Scott Webster"></span><meta itemprop=datePublished content=2020-07-10T16:00:48+00:00><meta itemprop=dateModified content=2020-07-10T15:43:27-04:00><meta itemscope itemprop=mainEntityOfPage itemType=https://schema.org/WebPage itemid=https://www.androidguys.com/reviews/accessory-reviews/gocube/><span style="display: none;" itemprop=publisher itemscope itemtype=https://schema.org/Organization><span style="display: none;" itemprop=logo itemscope itemtype=https://schema.org/ImageObject><meta itemprop=url content=https://www.androidguys.com/wp-content/uploads/2019/03/ag_logo_272_90.png></span><meta itemprop=name content=AndroidGuys></span><meta itemprop="headline " content="GoCube review"><span style="display: none;" itemprop=image itemscope itemtype=https://schema.org/ImageObject><meta itemprop=url content=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_03.jpg><meta itemprop=width content=1280><meta itemprop=height content=720></span></footer></article><div id=M265411ScriptRootC149654><div id=M265411PreloadC149654>
Loading...</div> <script data-cfasync=false>(function(){var D=new Date(),d=document,b='body',ce='createElement',ac='appendChild',st='style',ds='display',n='none',gi='getElementById',lp=d.location.protocol,wp=lp.indexOf('http')==0?lp:'https:';var i=d[ce]('iframe');i[st][ds]=n;d[gi]("M265411ScriptRootC149654")[ac](i);try{var iw=i.contentWindow.document;iw.open();iw.writeln("<ht"+"ml><bo"+"dy></bo"+"dy></ht"+"ml>");iw.close();var c=iw[b];}
catch(e){var iw=d;var c=d[gi]("M265411ScriptRootC149654");}var dv=iw[ce]('div');dv.id="MG_ID";dv[st][ds]=n;dv.innerHTML=149654;c[ac](dv);var s=iw[ce]('script');s.async='async';s.defer='defer';s.charset='utf-8';s.src=wp+"//jsc.mgid.com/a/n/androidguys.com.149654.js?t="+D.getYear()+D.getMonth()+D.getUTCDate()+D.getUTCHours();c[ac](s);})();</script> </div><div id=disqus_thread></div></div></div><div class="td-pb-span4 td-main-sidebar" role=complementary><div class=td-ss-main-sidebar><div class="td_block_wrap td_block_1 td_block_widget td_uid_5_5f08dbed25ee9_rand td-pb-border-top" data-td-block-uid=td_uid_5_5f08dbed25ee9><script>var block_td_uid_5_5f08dbed25ee9=new tdBlock();block_td_uid_5_5f08dbed25ee9.id="td_uid_5_5f08dbed25ee9";block_td_uid_5_5f08dbed25ee9.atts='{"limit":"1","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"The Latest","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_5_5f08dbed25ee9_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_5_5f08dbed25ee9_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';block_td_uid_5_5f08dbed25ee9.td_column_number="1";block_td_uid_5_5f08dbed25ee9.block_type="td_block_1";block_td_uid_5_5f08dbed25ee9.post_count="1";block_td_uid_5_5f08dbed25ee9.found_posts="26803";block_td_uid_5_5f08dbed25ee9.header_color="#";block_td_uid_5_5f08dbed25ee9.ajax_pagination_infinite_stop="";block_td_uid_5_5f08dbed25ee9.max_num_pages="26803";tdBlocksArray.push(block_td_uid_5_5f08dbed25ee9);</script><div class=td-block-title-wrap><h4 class="block-title"><span>The Latest</span></h4></div><div id=td_uid_5_5f08dbed25ee9 class=td_block_inner><div class=td-block-span12><div class="td_module_4 td_module_wrap td-animation-stack td-meta-info-hide"><div class=td-module-image><div class=td-module-thumb><a href=https://www.androidguys.com/guides/mint-mobile/ rel=bookmark title="Mint Mobile Buyer&#8217;s Guide"><img width=324 height=152 class=entry-thumb src=https://www.androidguys.com/wp-content/uploads/2019/12/mint_mobile_fox.png alt title="Mint Mobile Buyer&#8217;s Guide"></a></div></div><h3 class="entry-title td-module-title"><a href=https://www.androidguys.com/guides/mint-mobile/ rel=bookmark title="Mint Mobile Buyer&#8217;s Guide">Mint Mobile Buyer&#8217;s Guide</a></h3><div class=td-module-meta-info></div><div class=td-excerpt>
Mint Mobile provides excellent plans offered in multiple months as an alternative to its MVNO competitors. This serves as a guide for prospective customers.</div></div></div></div></div><div class="td-a-rec td-a-rec-id-custom_ad_2  "><div style="width:100%; text-align:center; margin:0"><span>Advertisements</span></div><div class=td-visible-desktop style=margin-top:5px;><div style='height:600px; width:300px; overflow:hidden;'><div id=div-gpt-ad-androidguyscom37010> <script data-cfasync=false>googletag.cmd.push(function(){googletag.display('div-gpt-ad-androidguyscom37010');});</script> </div>
<span class=bt-uid-tg data-uid=5c2fccf182-228 style='display: none !important'></span></div></div><div class=td-visible-phone><div style='height:250px; width:300px;'><div id=div-gpt-ad-1487238677738-0> <script data-cfasync=false>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1487238677738-0');});</script> </div></div></div></div><div class="td-a-rec td-a-rec-id-custom_ad_3  "><div style="width:100%; text-align:center; margin:0"><span>Advertisements</span></div><div class=td-visible-desktop style="height: 250px; width: 300px; overflow: hidden"><div id=div-gpt-ad-androidguyscom37008> <script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-androidguyscom37008');});</script> </div><span class=bt-uid-tg data-uid=5c2fccde72-228 style='display: none !important'></span></div></div><div class="td_block_wrap td_block_2 td_block_widget td_uid_8_5f08dbed27c90_rand td-pb-border-top" data-td-block-uid=td_uid_8_5f08dbed27c90><script>var block_td_uid_8_5f08dbed27c90=new tdBlock();block_td_uid_8_5f08dbed27c90.id="td_uid_8_5f08dbed27c90";block_td_uid_8_5f08dbed27c90.atts='{"limit":"4","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_8_5f08dbed27c90_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_8_5f08dbed27c90_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';block_td_uid_8_5f08dbed27c90.td_column_number="1";block_td_uid_8_5f08dbed27c90.block_type="td_block_2";block_td_uid_8_5f08dbed27c90.post_count="4";block_td_uid_8_5f08dbed27c90.found_posts="26803";block_td_uid_8_5f08dbed27c90.header_color="#";block_td_uid_8_5f08dbed27c90.ajax_pagination_infinite_stop="";block_td_uid_8_5f08dbed27c90.max_num_pages="6701";tdBlocksArray.push(block_td_uid_8_5f08dbed27c90);</script><div class=td-block-title-wrap></div><div id=td_uid_8_5f08dbed27c90 class=td_block_inner><div class=td-block-span12><div class="td_module_2 td_module_wrap td-animation-stack td-meta-info-hide"><div class=td-module-image><div class=td-module-thumb><a href=https://www.androidguys.com/guides/mint-mobile/ rel=bookmark title="Mint Mobile Buyer&#8217;s Guide"><img width=324 height=152 class=entry-thumb src=https://www.androidguys.com/wp-content/uploads/2019/12/mint_mobile_fox.png alt title="Mint Mobile Buyer&#8217;s Guide"></a></div></div><h3 class="entry-title td-module-title"><a href=https://www.androidguys.com/guides/mint-mobile/ rel=bookmark title="Mint Mobile Buyer&#8217;s Guide">Mint Mobile Buyer&#8217;s Guide</a></h3><div class=td-module-meta-info></div><div class=td-excerpt>
Mint Mobile provides excellent plans offered in multiple months as an alternative to its MVNO competitors. This serves as a guide for prospective customers.</div></div></div><div class=td-block-span12><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class=td-module-thumb><a href=https://www.androidguys.com/reviews/accessory-reviews/gocube/ rel=bookmark title="GoCube review"><img width=100 height=56 class=entry-thumb src=https://www.androidguys.com/wp-content/uploads/2020/07/gocube_03.jpg alt title="GoCube review"></a></div><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.androidguys.com/reviews/accessory-reviews/gocube/ rel=bookmark title="GoCube review">GoCube review</a></h3><div class=td-module-meta-info></div></div></div></div><div class=td-block-span12><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class=td-module-thumb><a href=https://www.androidguys.com/deals/stinger-car-vent-mount/ rel=bookmark title="This $12 magnetic phone holder is also a seat belt cutter and glass breaker"><img width=93 height=70 class=entry-thumb src=https://www.androidguys.com/wp-content/uploads/2020/07/stinger_black.jpg alt title="This $12 magnetic phone holder is also a seat belt cutter and glass breaker"></a></div><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.androidguys.com/deals/stinger-car-vent-mount/ rel=bookmark title="This $12 magnetic phone holder is also a seat belt cutter and glass breaker">This $12 magnetic phone holder is also a seat belt cutter...</a></h3><div class=td-module-meta-info></div></div></div></div><div class=td-block-span12><div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide"><div class=td-module-thumb><a href=https://www.androidguys.com/promoted-news/how-to-do-homework-6-expert-tips-and-tricks/ rel=bookmark title="How to do homework: 6 expert tips and tricks"><img width=100 height=67 class=entry-thumb src=https://www.androidguys.com/wp-content/uploads/2020/07/homework.png alt title="How to do homework: 6 expert tips and tricks"></a></div><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.androidguys.com/promoted-news/how-to-do-homework-6-expert-tips-and-tricks/ rel=bookmark title="How to do homework: 6 expert tips and tricks">How to do homework: 6 expert tips and tricks</a></h3><div class=td-module-meta-info></div></div></div></div></div></div><div class="td-a-rec td-a-rec-id-custom_ad_4  "><div style="width:100%; text-align:center; margin:0"><span>Advertisements</span></div><div class=td-visible-desktop style="height: 250px; width: 300px; overflow: hidden"><div id=div-gpt-ad-androidguyscom37009> <script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-androidguyscom37009');});</script> </div><span class=bt-uid-tg data-uid=5c2fccc6d2-228 style='display: none !important'></span></div></div><div class="td_block_wrap td_block_1 td_block_widget td_uid_10_5f08dbed2b631_rand td-pb-border-top" data-td-block-uid=td_uid_10_5f08dbed2b631><script>var block_td_uid_10_5f08dbed2b631=new tdBlock();block_td_uid_10_5f08dbed2b631.id="td_uid_10_5f08dbed2b631";block_td_uid_10_5f08dbed2b631.atts='{"limit":"1","sort":"","post_ids":"159300","tag_slug":"","autors_id":"","installed_post_types":"page","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_10_5f08dbed2b631_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_10_5f08dbed2b631_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';block_td_uid_10_5f08dbed2b631.td_column_number="1";block_td_uid_10_5f08dbed2b631.block_type="td_block_1";block_td_uid_10_5f08dbed2b631.post_count="0";block_td_uid_10_5f08dbed2b631.found_posts="0";block_td_uid_10_5f08dbed2b631.header_color="#";block_td_uid_10_5f08dbed2b631.ajax_pagination_infinite_stop="";block_td_uid_10_5f08dbed2b631.max_num_pages="0";tdBlocksArray.push(block_td_uid_10_5f08dbed2b631);</script><div class=td-block-title-wrap></div><div id=td_uid_10_5f08dbed2b631 class=td_block_inner></div></div></div></div></div></div></div><div class=td-footer-wrapper><div class=td-container><div class=td-pb-row><div class=td-pb-span12></div></div><div class=td-pb-row><div class=td-pb-span12></div></div></div><div class=td-footer-bottom-full><div class=td-container><div class=td-pb-row><div class=td-pb-span3><aside class=footer-logo-wrap><a href=https://www.androidguys.com/><img class=td-retina-data src=https://www.androidguys.com/wp-content/uploads/2019/03/ag_logo_272_90.png data-retina=https://www.androidguys.com/wp-content/uploads/2017/03/ag_logo_544_180.png alt=AndroidGuys title></a><a id=ot-sdk-btn class=ot-sdk-show-settings style="padding: 0; border: none">Change Ad Consent</a></aside></div><div class=td-pb-span5><aside class=footer-text-wrap><div class=block-title><span>ABOUT US</span></div>Now in our 12th year, AndroidGuys provides readers with the latest news and rumors around the Android and smartphone space. Coverage also includes reviews, opinion pieces, and tools to get more from your devices.<div class=footer-email-wrap>Contact us: <a href="/cdn-cgi/l/email-protection#5d2d2f382e2e1d3c33392f3234393a28242e733e3230"><span class="__cf_email__" data-cfemail="3d4d4f584e4e7d5c53594f5254595a48444e135e5250">[email&#160;protected]</span></a></div></aside></div><div class=td-pb-span4><aside class="footer-social-wrap td-social-style-2"><div class=block-title><span>FOLLOW US</span></div>
<span class=td-social-icon-wrap>
<a target=_blank href="https://www.facebook.com/androidguys" title=Facebook>
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class=td-social-icon-wrap>
<a target=_blank href="https://www.instagram.com/androidguys" title=Instagram>
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class=td-social-icon-wrap>
<a target=_blank href="https://www.androidguys.com/feed" title=RSS>
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class=td-social-icon-wrap>
<a target=_blank href="https://www.twitter.com/androidguys" title=Twitter>
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></aside></div></div></div></div></div><div class=td-sub-footer-container><div class=td-container><div class=td-pb-row><div class="td-pb-span7 td-sub-footer-menu"></div><div class="td-pb-span5 td-sub-footer-copy">
&copy;</div></div></div></div></div> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src=https://apis.google.com/js/plusone.js></script> <script>var amzn_ps_tracking_id="andro0eb-20";var amzn_ps_instance_id="3b2080bb-084f-4f79-9eca-229a944a5a5f";</script> <script async=true type=text/javascript src=//ps-us.amazon-adsystem.com/scripts/US/studio.js charset=UTF-8></script> <script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=f8a9d144-449a-4897-8c59-9d53e8826517"></script> <script type=application/javascript src="https://www9.smartadserver.com/ac?out=js&nwid=1331&siteid=94704&pgname=.2_11159.3_androidguys.com_tier1_/hi/&fmtid=44627&tgt=[sas_target]&visit=m&tmstp=[timestamp]&clcturl=[countgo]"></script> <script type=application/javascript src="https://www9.smartadserver.com/ac?out=js&nwid=1331&siteid=94704&pgname=.2_11160.5_androidguys.com_tier1_/hi/&fmtid=44627&tgt=[sas_target]&visit=m&tmstp=[timestamp]&clcturl=[countgo]"></script> <script src=//s.skimresources.com/js/75515X1525641.skimlinks.js></script> <script data-cfasync=false type=text/javascript>(function(){var s=document.createElement('script');s.type='text/javascript';s.async=true;s.src='//nextmillennium.liqwid.net/?key=D85D-A6F1-B041-B88A';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);})();</script> 
<style type=text/css media=screen>a {
text-decoration-color:#EA215A;
text-decoration-thickness:.125em;
text-underline-offset:1.5px;
}

@media (min-width: 768px) and (max-width: 1018px) {
.td-pb-span8 {
width:440px;
}

.td-pb-span4 {
width:328px;
}
}</style> <script type=text/javascript>function getBrowserSize(){var w,h;if(typeof window.innerWidth!='undefined')
{w=window.innerWidth;h=window.innerHeight;}
else if(typeof document.documentElement!='undefined'&&typeof document.documentElement.clientWidth!='undefined'&&document.documentElement.clientWidth!==0)
{w=document.documentElement.clientWidth;h=document.documentElement.clientHeight;}
else{w=document.body.clientWidth;h=document.body.clientHeight;}
return{'width':w,'height':h};}
if(parseInt(getBrowserSize().width)<=768){var spots=document.getElementsByClassName("td-visible-desktop");for(let i=0;i<spots.length;i++){spots[i].remove();}}
else{var spots=document.getElementsByClassName("td-visible-phone");for(let i=0;i<spots.length;i++){spots[i].remove();}}<script type="text/javascript"src=https://cdn.cookielaw.org/consent/2a5060da-ede3-4571-880b-f3f37b55bd7b/OtAutoBlock.js></script> <script src=https://cdn.cookielaw.org/scripttemplates/otSDKStub.js type=text/javascript charset=UTF-8 data-domain-script=2a5060da-ede3-4571-880b-f3f37b55bd7b></script> <script type=text/javascript>function OptanonWrapper(){}</script> </script><link rel=stylesheet id=aal_style-css href='https://www.androidguys.com/wp-content/plugins/wp-auto-affiliate-links/css/style.css?ver=5.2.7' type=text/css media=all> <script type=text/javascript>var countVars={"disqusShortname":"androidguys"};</script> <script type=text/javascript src='https://www.androidguys.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script> <script type=text/javascript>var embedVars={"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"163281 https:\/\/www.androidguys.com\/?p=163281","disqusShortname":"androidguys","disqusTitle":"GoCube review","disqusUrl":"https:\/\/www.androidguys.com\/reviews\/accessory-reviews\/gocube\/","postId":"163281"};</script> <script type=text/javascript src='https://www.androidguys.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script> <script type=text/javascript>var aal_amazon_obj=[];</script> <script type=text/javascript src='https://www.androidguys.com/wp-content/plugins/wp-auto-affiliate-links/js/api.js?ver=5.2.7'></script> <script type=text/javascript src='https://www.androidguys.com/wp-content/themes/Newspaper2/js/tagdiv_theme.js?ver=7.6.1'></script> <script type=text/javascript src='https://www.androidguys.com/wp-includes/js/comment-reply.min.js?ver=5.2.7'></script> <script type=text/javascript src='https://www.androidguys.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=3.0.0-beta.1'></script> <script type=text/javascript src='https://www.androidguys.com/wp-includes/js/wp-embed.min.js?ver=5.2.7'></script> <script>(function(){var html_jquery_obj=jQuery('html');if(html_jquery_obj.length&&(html_jquery_obj.is('.ie8')||html_jquery_obj.is('.ie9'))){var path='https://www.androidguys.com/wp-content/themes/Newspaper2/style.css';jQuery.get(path,function(data){var str_split_separator='#td_css_split_separator';var arr_splits=data.split(str_split_separator);var arr_length=arr_splits.length;if(arr_length>1){var dir_path='https://www.androidguys.com/wp-content/themes/Newspaper2';var splited_css='';for(var i=0;i<arr_length;i++){if(i>0){arr_splits[i]=str_split_separator+' '+arr_splits[i];}
var formated_str=arr_splits[i].replace(/\surl\(\'(?!data\:)/gi,function regex_function(str){return' url(\''+dir_path+'/'+str.replace(/url\(\'/gi,'').replace(/^\s+|\s+$/gm,'');});splited_css+="<style></style>";}
var td_theme_css=jQuery('link#td-theme-css');if(td_theme_css.length){td_theme_css.after(splited_css);}}});}})();</script> <script data-cfasync=false>var contentPara=Array.from(document.querySelectorAll('.td-post-content>p'));if(contentPara.length>=5){var targetPara=contentPara[5];var insertedDiv=document.createElement("div");insertedDiv.id='div-gpt-ad-androidguyscom35113';var insertedScript=document.createElement("script");function insertAfter(el,referenceNode){referenceNode.parentNode.insertBefore(el,referenceNode.nextSibling);}
insertAfter(insertedDiv,targetPara)
insertedScript.text="googletag.cmd.push(function() { googletag.display('div-gpt-ad-androidguyscom35113'); });";insertedDiv.append(insertedScript);googletag.pubads().refresh([pgSlot35113]);}</script> <script data-cfasync=false src=//dsh7ky7308k4b.cloudfront.net/autoads/androidguyscom.min.js?v2></script> </body></html>